[kovarex] [0.16.41] Circuit controlled train signals not converted properly

This subforum contains all the issues which we already resolved.
Post Reply
Calibretto22
Burner Inserter
Burner Inserter
Posts: 9
Joined: Thu May 03, 2018 8:54 pm
Contact:

[kovarex] [0.16.41] Circuit controlled train signals not converted properly

Post by Calibretto22 » Thu May 03, 2018 9:08 pm

Gamestate: Vanilla - no mods

If you load a savegame that was created with game-version 0.16.39 to game version 0.16.41 rail signals that are circuit-controlled are not converted properly.
the circuit condition to close the the signal is ignored by the train.
normal train signal function is maintained - the trains won't crash.

problem does not occur when train signals are placed in version .41.

i created a small savegame in version .39.
if you load it to version .41 you can experience the bug.
(the trains should stop at the train signal that is circuit controlled.)

Savegame: https://drive.google.com/open?id=1R2cTT ... j6ynh14YXC
Blueprint

c0bRa
Long Handed Inserter
Long Handed Inserter
Posts: 67
Joined: Sun Nov 13, 2016 8:33 pm
Contact:

Re: [0.16.41] Circuit controlled train signals not converted properly

Post by c0bRa » Thu May 03, 2018 10:03 pm

It seems that the initial signal was green although the condition matched. I‘ve manually set the condition false for each signal and reset them afterwards. Then it works as intended. Took me 2 hours but now everything is moving well in .41 ;)

I am glad that i can play my save, with the .39 bug i thought i can delete it... :)

Dune
Fast Inserter
Fast Inserter
Posts: 162
Joined: Tue Dec 12, 2017 4:27 am
Contact:

Re: [0.16.41] Circuit controlled train signals not converted properly

Post by Dune » Fri May 04, 2018 6:31 am

I can confirm. Taking my map from 39 to 41, all stations that have signal controls for when a train should arrive are ignored, causing trains to enter the station when another train is already there, or enter stations that aren't ready for them.
Image

User avatar
husky777
Burner Inserter
Burner Inserter
Posts: 17
Joined: Wed Jan 18, 2017 9:46 am
Contact:

Re: [0.16.41] Circuit controlled train signals not converted properly

Post by husky777 » Fri May 04, 2018 11:33 am

+
have the same problem
This text is written in broken English
greetings from the Russian Federation

looney
Inserter
Inserter
Posts: 33
Joined: Wed Nov 04, 2015 11:44 am
Contact:

Re: [0.16.41] Circuit controlled train signals not converted properly

Post by looney » Sat May 05, 2018 12:43 am

I also made a small reproducer;
Screenshot from 2018-05-05 10-05-11.png
Screenshot from 2018-05-05 10-05-11.png (2.62 MiB) Viewed 1892 times
Screenshot from 2018-05-05 10-07-09.png
Screenshot from 2018-05-05 10-07-09.png (2.63 MiB) Viewed 1892 times
Attachments
0.16.39 signals.zip
(1.65 MiB) Downloaded 35 times

mathturtle
Inserter
Inserter
Posts: 39
Joined: Sat Jan 21, 2017 8:19 pm
Contact:

Re: [0.16.41] Circuit controlled train signals not converted properly

Post by mathturtle » Sat May 05, 2018 4:01 pm

I can also confirm this.

kovarex
Factorio Staff
Factorio Staff
Posts: 7424
Joined: Wed Feb 06, 2013 12:00 am
Contact:

Re: [kovarex] [0.16.41] Circuit controlled train signals not converted properly

Post by kovarex » Wed May 09, 2018 12:01 pm

Fixed for 0.16.42.

The error is *only* as long as the signal stays the same. It fixes itself the first time the signal changes, but still, it is a bug.

Thanks for the report.

Dune
Fast Inserter
Fast Inserter
Posts: 162
Joined: Tue Dec 12, 2017 4:27 am
Contact:

Re: [kovarex] [0.16.41] Circuit controlled train signals not converted properly

Post by Dune » Thu May 10, 2018 8:29 am

Thanks for getting this one. I've been waiting to upgrade until this was fixed.
Image

looney
Inserter
Inserter
Posts: 33
Joined: Wed Nov 04, 2015 11:44 am
Contact:

Re: [kovarex] [0.16.41] Circuit controlled train signals not converted properly

Post by looney » Thu May 10, 2018 1:28 pm

kovarex wrote:Fixed for 0.16.42.

The error is *only* as long as the signal stays the same. It fixes itself the first time the signal changes, but still, it is a bug.

Thanks for the report.
Hmmm, I'm not certain this is true, or there's something else that needs to be fixed too. I swear I've seen a constant stream of trains enter a station with no items waiting.... (reloads
simple_0.16.zip
(54.03 MiB) Downloaded 42 times
)

Yep here's an example, walk to the SE from where you'll spawn, to my iron plate pickup stations;
Screenshot from 2018-05-10 22-44-31.png
Screenshot from 2018-05-10 22-44-31.png (1.47 MiB) Viewed 1647 times
I stood there for a while, and there were a constant stream of trains, each leaving after 5s of inactivity.

looney
Inserter
Inserter
Posts: 33
Joined: Wed Nov 04, 2015 11:44 am
Contact:

Re: [kovarex] [0.16.41] Circuit controlled train signals not converted properly

Post by looney » Thu May 10, 2018 11:14 pm

Or did I misunderstand what you meant?

I assumed you were saying that everything would be fixed when the rail signal changed, did you mean that everything would be fixed when the circuit condition "signal" changed?

That would actually explain the behaviour I've seen, where only some of my rail signals seemed to be stuck open, while others seem to be working fine.

Post Reply

Return to “Resolved Problems and Bugs”

Who is online

Users browsing this forum: No registered users