[Twinsen] [0.16.38] Crash when loading autosave

This subforum contains all the issues which we already resolved.
Post Reply
psihius
Fast Inserter
Fast Inserter
Posts: 189
Joined: Mon Dec 15, 2014 12:47 am
Contact:

[Twinsen] [0.16.38] Crash when loading autosave

Post by psihius » Mon Apr 30, 2018 2:10 pm

Server was stopped to update mods, on startup got a crash.

Archive with logs, dump, mods and save attached.
Attachments
crash.zip
(40.98 MiB) Downloaded 33 times

psihius
Fast Inserter
Fast Inserter
Posts: 189
Joined: Mon Dec 15, 2014 12:47 am
Contact:

Re: [Twinsen] [0.16.38] Crash when loading autosave

Post by psihius » Mon Apr 30, 2018 2:31 pm

Mod author did this: https://github.com/Danielv123/factorioC ... 86633b39be

And someone had a circuit connection on the chest, that was setting the requests for items via circuitry.

I fixed it by loading game without the mods, all chests got removed, now just manually will replace them (we had only a few in this save).

Twinsen
Factorio Staff
Factorio Staff
Posts: 1033
Joined: Tue Sep 23, 2014 7:10 am
Contact:

Re: [Twinsen] [0.16.38] Crash when loading autosave

Post by Twinsen » Tue May 01, 2018 1:29 pm

The problem was it was trying to reconnect the circuit network entities without having all the entities loaded to know what to connect to.

Unfortunately this means the fix is that whenever a connected entity is migrated to something else, it's wires will be disconnected.

Fixed in Version: 0.16.40

Post Reply

Return to “Resolved Problems and Bugs”

Who is online

Users browsing this forum: No registered users