[0.16.37]Barrel graphics is wrong/no color overlay

This subforum contains all the issues which we already resolved.
Post Reply
Echo51
Burner Inserter
Burner Inserter
Posts: 8
Joined: Sat Aug 29, 2015 6:53 pm
Contact:

[0.16.37]Barrel graphics is wrong/no color overlay

Post by Echo51 » Mon Apr 23, 2018 9:21 pm

Image
Barrels are missing their overlay/coloring. This wasn't an issue in 0.16.36, same save exhibits this issue when loading in .37, having just been saved and verified working in .36

User avatar
Deadlock989
Filter Inserter
Filter Inserter
Posts: 995
Joined: Fri Nov 06, 2015 7:41 pm
Contact:

Re: [0.16.37]Barrel graphics is wrong/no color overlay

Post by Deadlock989 » Tue Apr 24, 2018 7:54 am

I've had a report of a similar problem with my mods, which use the same tinted layer technique as barrels.

Tested this on an old laptop. Recipe icons in the crafting tab are rendered correctly, but item icons in the main inventory that use icons instead of icon are all missing every layer above the base one.
Attachments
Untitled.png
Untitled.png (252.44 KiB) Viewed 2162 times

User avatar
bobingabout
Smart Inserter
Smart Inserter
Posts: 6735
Joined: Fri May 09, 2014 1:01 pm
Contact:

Re: [0.16.37]Barrel graphics is wrong/no color overlay

Post by bobingabout » Tue Apr 24, 2018 9:12 am

Yeah, I'm getting reports that my MK2 and MK3 logistic chests look wrong.
I'm told that they all just look like Titanium chests, so only the first layer is being loaded?

an example of the icon.

Code: Select all

    icons = {
      {
        icon = "__boblogistics__/graphics/icons/titanium-chest.png",
      },
      {
        icon = "__boblogistics__/graphics/entity/logistic-chest/logistic-chest-port.png",
      },
      {
        icon = "__boblogistics__/graphics/entity/logistic-chest/logistic-chest-mask.png",
        tint = {r = 0.9, g = 0.2, b = 0.1, a = 1}
      }
    },
Apparently it looks right in the recipe list, but wrong on the item icon.

I have not checked it myself yet, but I'm confident that this is the same bug.
Creator of Bob's mods. Expanding your gameplay since version 0.9.8.
I also have a Patreon.

Echo51
Burner Inserter
Burner Inserter
Posts: 8
Joined: Sat Aug 29, 2015 6:53 pm
Contact:

Re: [0.16.37]Barrel graphics is wrong/no color overlay

Post by Echo51 » Tue Apr 24, 2018 9:45 am

Just to clarify, this still happend after loading without any mods enabled.

https://www.reddit.com/r/factorio/comme ... ure_issue/
This guy seems to have the same issue aswell.

Post Reply

Return to “Resolved Problems and Bugs”

Who is online

Users browsing this forum: Google [Bot]