[rseding91] Missing translation strings in multiplayer server list

This subforum contains all the issues which we already resolved.
Post Reply
Koltrast
Inserter
Inserter
Posts: 38
Joined: Sun Oct 09, 2016 9:40 pm
Contact:

[rseding91] Missing translation strings in multiplayer server list

Post by Koltrast » Tue Mar 13, 2018 10:55 am

Hello!
te game is fully translated into my language but i have saw a string not translated i can't find in crowdin.

when I load the multiplayer game list and there is a connection error, the error displayed is in english.
i can't remember exact words, but it says something about slow connection issues.

User avatar
Kayanor
Global Moderator
Global Moderator
Posts: 558
Joined: Sat May 10, 2014 7:20 am
Contact:

Re: Missing string

Post by Kayanor » Tue Mar 13, 2018 12:04 pm

Can you please tell me the language in question and/or show me the the error message so I can take a look at it? :)

Koltrast
Inserter
Inserter
Posts: 38
Joined: Sun Oct 09, 2016 9:40 pm
Contact:

Re: Missing string

Post by Koltrast » Tue Mar 13, 2018 1:57 pm

Kayanor wrote:Can you please tell me the language in question and/or show me the the error message so I can take a look at it? :)

italian.
the error is not simple to reproduce, it's appeared when i had a slow connection.
but I've restarted my router then i tried to reload the multiplayer browser and this other messages are appeared, see attached files.
Attachments
20180313143957_1.jpg
20180313143957_1.jpg (326.99 KiB) Viewed 1006 times
20180313143932_1.jpg
20180313143932_1.jpg (274.4 KiB) Viewed 1006 times

User avatar
Kayanor
Global Moderator
Global Moderator
Posts: 558
Joined: Sat May 10, 2014 7:20 am
Contact:

Re: Missing string

Post by Kayanor » Tue Mar 13, 2018 2:37 pm

Thank you for providing the screenshots, I will move this to the bug reports section as these strings seem to be missing in the translation files.

Rseding91
Factorio Staff
Factorio Staff
Posts: 9478
Joined: Wed Jun 11, 2014 5:23 am
Contact:

Re: [Dominik] Missing translation strings in multiplayer server list

Post by Rseding91 » Sat Mar 17, 2018 10:41 pm

Thanks for the report. I localized the errors from our side of the logic however there are still errors that the HTTPS library we use generates which aren't localized.

I'll leave that up to one of the other developers to decide if we want to modify the library to support localizing the errors it generates.
If you want to get ahold of me I'm almost always on Discord.

Koltrast
Inserter
Inserter
Posts: 38
Joined: Sun Oct 09, 2016 9:40 pm
Contact:

Re: [Dominik] Missing translation strings in multiplayer server list

Post by Koltrast » Tue Mar 20, 2018 8:44 am

Rseding91 wrote:Thanks for the report. I localized the errors from our side of the logic however there are still errors that the HTTPS library we use generates which aren't localized.

I'll leave that up to one of the other developers to decide if we want to modify the library to support localizing the errors it generates.
:D

I have translated it.

bye!

Post Reply

Return to “Resolved Problems and Bugs”

Who is online

Users browsing this forum: No registered users