[kovarex] [0.16.30] Ghost placed rail signals are broken

This subforum contains all the issues which we already resolved.
Post Reply
Sifu
Burner Inserter
Burner Inserter
Posts: 15
Joined: Sat Dec 02, 2017 12:59 am
Contact:

[kovarex] [0.16.30] Ghost placed rail signals are broken

Post by Sifu » Tue Mar 13, 2018 12:16 am

What did you do?
I placed a ghost rail signal on a ghost rail.

What happened?
It did not attach to the rail (Blinks green/yellow/red)

What did you expect to happen instead?
Attach to the rail as if I placed it (ghost placed or not).

I made a video that also shows that shows this issue and that ghost signals can be placed ANYWHERE and remembers the orientation of the last correct placement.
I would suggest:
- Disable the ability of ghost placing signals anywhere except correct placements (same behavior as placed by hand)
- (Cherry on top) Enable ghost placement of signals on ghost rails

https://youtu.be/Nz9l0hMVRmA

Currently you have to wait until the rails were built by the bots before placing the signals.


I don't think my logs are necessary since this is a gameplay "bug(?)". But sure will provide if necessary.

kovarex
Factorio Staff
Factorio Staff
Posts: 7077
Joined: Wed Feb 06, 2013 12:00 am
Contact:

Re: [kovarex] [0.16.30] Ghost placed rail signals are broken

Post by kovarex » Tue Mar 13, 2018 7:43 am

The problem is, that you built the signal in the wrong direction.
When building signals no non ghost rails, the direction of the signal is selected automatically to match the nearby rail (if more rails are nearby, pressing R switches between the variants).
But when building next to ghost rail, this mechanism is not there, and you can build the signals in opposite direction, thus the signal doesn't connect, as it expect rail on the other side.
If you try to rotate the signal and build it, you will see that it will connect.

I agree, that this is little bit weird, so I changed for 0.16.31, so rail signal direction auto-selection takes ghost rails into consideration.

mrvn
Smart Inserter
Smart Inserter
Posts: 2978
Joined: Mon Sep 05, 2016 9:10 am
Contact:

Re: [kovarex] [0.16.30] Ghost placed rail signals are broken

Post by mrvn » Tue Mar 13, 2018 11:44 am

Thanks. I always found it hard to see which direction a ghost signal was facing and if it even was allowed at a certain spot.

Did you fix the placement of train stops to consider ghost rails too?

What about placing chests or inserters next to ghost rails or ghost stops? Will the helpful white boxes appear showing where train cars will be?

kovarex
Factorio Staff
Factorio Staff
Posts: 7077
Joined: Wed Feb 06, 2013 12:00 am
Contact:

Re: [kovarex] [0.16.30] Ghost placed rail signals are broken

Post by kovarex » Mon Oct 15, 2018 7:27 pm

This thing was only done on my laptop and never actually pushed to our code base. I discovered it today, so I pushed it for 0.17

Post Reply

Return to “Resolved Problems and Bugs”

Who is online

Users browsing this forum: No registered users and 5 guests