[Posila] [0.16.29] Corrupted graphics - SOLVED

This subforum contains all the issues which we already resolved.
Post Reply
StarLite
Burner Inserter
Burner Inserter
Posts: 5
Joined: Mon Mar 12, 2018 6:01 pm
Contact:

[Posila] [0.16.29] Corrupted graphics - SOLVED

Post by StarLite » Mon Mar 12, 2018 6:04 pm

Since updating to 0.16.29 my graphics have become corrupted. It seems to have to do with transparent textures/color overlays:
Affected things: clouds, trains (locomotives and wagons), radars

Image
Image

0.16.29 on steam, verified game files
i5 2500k
RX480 with the latest drivers
Windows 10

I have fiddled with the ingame settings, but I can't find any specific settings that solve the issue.
The weird blocks move like the clouds, turning off clouds removes them, the other corrupt textures remain tho. Restarting the game gives me different textures instead of the clouds every time I restart.

Gizan
Manual Inserter
Manual Inserter
Posts: 1
Joined: Mon Mar 12, 2018 6:19 pm
Contact:

Re: [0.16.29] Corrupted graphics

Post by Gizan » Mon Mar 12, 2018 6:22 pm

I had the same issue with Factorio this morning with [0.16.29] update. Turning off clouds got rid of the full screen graphical bugs, but inserter and item shadows still give issues. turning these off did nothing to help fix it.


i-7 6700k
GTX 1080 X2 (Newest drivers)
2x 512gb SSD
64 GB memory
windows 10 x64

thegodzilla25
Manual Inserter
Manual Inserter
Posts: 1
Joined: Mon Mar 12, 2018 6:21 pm
Contact:

Re: [0.16.29] Corrupted graphics

Post by thegodzilla25 » Mon Mar 12, 2018 6:28 pm

Can confirm, same issue.
Made a post on reddit. https://www.reddit.com/r/factorio/comme ... ah_humbug/
Seems to be affecting trains, radars, artillery, tracks. And some blue translucent rectangles were also floating by.

Specs
Intel Core 2 Duo E8400 3 Ghz
Nvidia GT 640, latest driver
Factorio 0.16.29
Windows 10 Pro

Rseding91
Factorio Staff
Factorio Staff
Posts: 9977
Joined: Wed Jun 11, 2014 5:23 am
Contact:

Re: [0.16.29] Corrupted graphics

Post by Rseding91 » Mon Mar 12, 2018 6:35 pm

There's a suspicious lack of log files here :P (please everyone who is having the issue upload your factorio-current.log file here)
If you want to get ahold of me I'm almost always on Discord.

MrUrist
Manual Inserter
Manual Inserter
Posts: 1
Joined: Mon Mar 12, 2018 6:51 pm
Contact:

Re: [0.16.29] Corrupted graphics

Post by MrUrist » Mon Mar 12, 2018 6:56 pm

Same problem, even worse with clouds turned on.
Attachments
factorio-current.log
(3.76 KiB) Downloaded 43 times

StarLite
Burner Inserter
Burner Inserter
Posts: 5
Joined: Mon Mar 12, 2018 6:01 pm
Contact:

Re: [0.16.29] Corrupted graphics

Post by StarLite » Mon Mar 12, 2018 6:59 pm

Here's my current.log
Attachments
factorio-current.log
(7.95 KiB) Downloaded 43 times

User avatar
ETM654
Inserter
Inserter
Posts: 28
Joined: Wed Mar 07, 2018 10:13 pm
Contact:

Re: [0.16.29] Corrupted graphics

Post by ETM654 » Mon Mar 12, 2018 7:16 pm

Confirmed for tanks
Attachments
factorio-current.log
(4.04 KiB) Downloaded 36 times
20180312151039_1.jpg
20180312151039_1.jpg (619.34 KiB) Viewed 3533 times

StarLite
Burner Inserter
Burner Inserter
Posts: 5
Joined: Mon Mar 12, 2018 6:01 pm
Contact:

Re: [0.16.29] Corrupted graphics

Post by StarLite » Mon Mar 12, 2018 7:19 pm

It's ok as long as I dont resize the Factorio window (I play in windowed mode). As soon as I resize the window, it starts to go all weird :)
Switching to fullscreen after starting the game does not solve the issue, the textures stay broken.
Last edited by StarLite on Mon Mar 12, 2018 7:21 pm, edited 1 time in total.

User avatar
ETM654
Inserter
Inserter
Posts: 28
Joined: Wed Mar 07, 2018 10:13 pm
Contact:

Re: [0.16.29] Corrupted graphics

Post by ETM654 » Mon Mar 12, 2018 7:21 pm

StarLite wrote:It's ok as long as I dont resize the Factorio window (I play in windowed mode). As soon as I resize the window, it starts to go all weird :)
Yeah mine didn't break until I" alt-tabbed" out of the game for a second

KodaTheGiraffe
Manual Inserter
Manual Inserter
Posts: 1
Joined: Mon Mar 12, 2018 7:21 pm
Contact:

Re: [0.16.29] Corrupted graphics

Post by KodaTheGiraffe » Mon Mar 12, 2018 7:24 pm

Happening to me as well. Ryzen 7 1800x, gtx 960.
Attachments
factorio-current.log
(4.32 KiB) Downloaded 33 times

User avatar
ETM654
Inserter
Inserter
Posts: 28
Joined: Wed Mar 07, 2018 10:13 pm
Contact:

Re: [0.16.29] Corrupted graphics

Post by ETM654 » Mon Mar 12, 2018 7:25 pm

Closing the game completely then restarting the game fixed it for me

luziferius
Inserter
Inserter
Posts: 24
Joined: Thu Jun 01, 2017 12:59 pm
Contact:

Re: [0.16.29] Corrupted graphics

Post by luziferius » Mon Mar 12, 2018 7:44 pm

Currently, all logs are from the windows version. GPU vendor is mixed (AMD, NVidia).
Maybe try to force the game to use the OpenGL renderer to see if this is specific to the Direct3D renderer:


Open config\config.ini in the user data directory (https://wiki.factorio.com/Application_directory)
Then enable the force-opengl option by removing the »; « in front and set it to force-opengl=true

Start the game again. If everything renders fine after enabing OpenGL, it is a Direct3D issue (maybe in combination with specific hardware/driver versions).

Those issues look like being related to transparency. As this is not in the log: What are your exact graphics settings?
There is this in config.ini, is it enabled for you? It is marked as maybe causing issues.

Code: Select all

; Alpha masks are loaded as single channel textures. This may cause problems on some configurations.
; 
; Options: true, false
single-channel-textures=true

StarLite
Burner Inserter
Burner Inserter
Posts: 5
Joined: Mon Mar 12, 2018 6:01 pm
Contact:

Re: [0.16.29] Corrupted graphics

Post by StarLite » Mon Mar 12, 2018 7:53 pm

Switching to OpenGL fixes the problem for me :)
Single channel textures are off for me
Image

Rseding91
Factorio Staff
Factorio Staff
Posts: 9977
Joined: Wed Jun 11, 2014 5:23 am
Contact:

Re: [0.16.29] Corrupted graphics

Post by Rseding91 » Mon Mar 12, 2018 8:15 pm

Thanks for all the information. We found the issue and it's now fixed for the next version of 0.16.

In the meantime if you use video memory usage = all it bypasses the problem. We'll most likely release the next version of 0.16 either later today or early tomorrow morning.
If you want to get ahold of me I'm almost always on Discord.

StarLite
Burner Inserter
Burner Inserter
Posts: 5
Joined: Mon Mar 12, 2018 6:01 pm
Contact:

Re: [Posila] [0.16.29] Corrupted graphics - SOLVED

Post by StarLite » Mon Mar 12, 2018 8:41 pm

I can confirm that setting video memory to all fixes it for me :)
2 hours from report to fix, you guys are friggin' amazing! :D

Kaz92
Manual Inserter
Manual Inserter
Posts: 3
Joined: Sun Sep 21, 2014 4:55 pm
Contact:

Re: [Posila] [0.16.29] Corrupted graphics - SOLVED

Post by Kaz92 » Mon Mar 12, 2018 9:13 pm

Good to know this bug has been nailed already :)

Found my own verison of the drawing issue with radar stations, and possibly wind indicators? :lol:

https://youtu.be/rAw92hvd08U

posila
Factorio Staff
Factorio Staff
Posts: 3992
Joined: Thu Jun 11, 2015 1:35 pm
Contact:

Re: [Posila] [0.16.29] Corrupted graphics - SOLVED

Post by posila » Mon Mar 12, 2018 10:41 pm

I tried to improve handling of running out of video memory and made a mistage that affected almost everyone. I am sorry for that :)
Thanks for all the reports.
The issue has been fixed in 0.16.30 which is already available.

User avatar
nemostein
Long Handed Inserter
Long Handed Inserter
Posts: 54
Joined: Mon Apr 10, 2017 8:39 pm
Contact:

Re: [Posila] [0.16.29] Corrupted graphics - SOLVED

Post by nemostein » Tue Mar 13, 2018 11:21 am

posila wrote:... made a mistage ...
Mistages. Mistages everywhere... :p

Fantastic job, by the way... Thank you! = ]
"I'd say the main bottleneck is sleep." - AndrewIRL

posila
Factorio Staff
Factorio Staff
Posts: 3992
Joined: Thu Jun 11, 2015 1:35 pm
Contact:

Re: [Posila] [0.16.29] Corrupted graphics - SOLVED

Post by posila » Tue Mar 13, 2018 11:28 am

nemostein wrote:
posila wrote:... made a mistage ...
Mistages. Mistages everywhere... :p

Fantastic job, by the way... Thank you! = ]
K and G are just 3 keys apart and I have fat fingers, give me a break :D :D

WarpZone
Inserter
Inserter
Posts: 38
Joined: Mon Feb 13, 2017 9:39 pm
Contact:

Re: [Posila] [0.16.29] Corrupted graphics - SOLVED

Post by WarpZone » Wed Mar 14, 2018 1:31 am

Is your name Atrus? You keep making all these Mistages. :lol:

Post Reply

Return to “Resolved Problems and Bugs”

Who is online

Users browsing this forum: No registered users