[Rseding91] [16.27] Crash: "Removal of trains over rail unsucessful: 1 != 0, before: 1."

This subforum contains all the issues which we already resolved.
Post Reply
randomnick4me
Manual Inserter
Manual Inserter
Posts: 3
Joined: Sun Mar 04, 2018 4:30 am
Contact:

[Rseding91] [16.27] Crash: "Removal of trains over rail unsucessful: 1 != 0, before: 1."

Post by randomnick4me » Sun Mar 04, 2018 4:40 am

Hi,

I've built a 3K SPM base with 100+ trains using LTN and FARL and NewGame+. I was trying to launch to a new planet to start over and it kept crashing. 10% of the time it would succeed in starting a new world when I disabled FARL + LTN and changed no settings. Whenever I change a setting and relaunch I have yet to get a successful restart.

I have attached the current log. The problem always seems to arise when dealing with trains.

In other possibly related issues (might be mod specific) but the underlying cause might be the same - When I use LTN and mine a station about 50% of the time the game crashes somewhere in the LTN Lua code. I didn't capture a crash dump from that but if I do I will attach it.

Thanks for creating a remarkably stable and enjoyable game.
Attachments
FactorioMods.zip
Alien Biomes High Res Terrain removed
(103.93 MiB) Downloaded 41 times
factorio-current.log
Current from crash
(18.63 KiB) Downloaded 42 times
factorio-dump-current.dmp
(605.94 KiB) Downloaded 62 times
PrepNewWorld5-NoFarlNoLTN.zip
Save File - LTN and FARL disabled
(52.06 MiB) Downloaded 51 times
factorio-current.log
(18.58 KiB) Downloaded 40 times
Last edited by randomnick4me on Sun Mar 04, 2018 5:06 am, edited 2 times in total.

Loewchen
Global Moderator
Global Moderator
Posts: 5348
Joined: Wed Jan 07, 2015 5:53 pm
Contact:

Re: [16.27] Crash: "Removal of trains over rail unsucessful: 1 != 0, before: 1."

Post by Loewchen » Sun Mar 04, 2018 4:43 am

Post the save, the .ziped mods folder and the crash dump please.

randomnick4me
Manual Inserter
Manual Inserter
Posts: 3
Joined: Sun Mar 04, 2018 4:30 am
Contact:

Re: [16.27] Crash: "Removal of trains over rail unsucessful: 1 != 0, before: 1."

Post by randomnick4me » Sun Mar 04, 2018 4:57 am

Uploaded and attached to original post. Had to remove alien biomes high res terrain to get file size down to upload limits.

Rseding91
Factorio Staff
Factorio Staff
Posts: 9789
Joined: Wed Jun 11, 2014 5:23 am
Contact:

Re: [Rseding91] [16.27] Crash: "Removal of trains over rail unsucessful: 1 != 0, before: 1."

Post by Rseding91 » Mon Mar 05, 2018 2:01 pm

Thanks for the report and the save file. It's now fixed for the next version of 0.16.
If you want to get ahold of me I'm almost always on Discord.


Post Reply

Return to “Resolved Problems and Bugs”

Who is online

Users browsing this forum: No registered users