[0.16.X] Biters randomly destroying power poles

This subforum contains all the issues which we already resolved.
Post Reply
sinsiliux
Inserter
Inserter
Posts: 32
Joined: Mon May 19, 2014 12:40 am
Contact:

[0.16.X] Biters randomly destroying power poles

Post by sinsiliux » Thu Mar 01, 2018 1:10 pm

First let me start with this: I know that biters destroy power poles if they are inside forests and biters get stuck and need to create a path for themselves.
I've started a new game since 0.16 update and I've noticed that from time to time my large power poles get destroyed. It happens very rarely so catching it in action is quite hard, but I've loaded a save today and 5 seconds later my power pole got destroyed. So I've reloaded my save and used

Code: Select all

/c game.forces.player.chart(game.player.surface, {lefttop = {x = -1024, y = -1024}, rightbottom = {x = 1024, y = 1024}})
to checkout what's going on in there. It seems that most biters path around the power pole except the last one, who decides to suddenly turn around and destroy the pole.
I'm not 100% sure if this is a bug, but it seems like a bug to me, since that biter didn't have any reason to attack the power pole as it wasn't in biter's way and power poles don't produce any polution. I've attached the save file.
Attachments
free.zip
Save to reproduce the bug
(12.6 MiB) Downloaded 46 times

Oxyd
Factorio Staff
Factorio Staff
Posts: 1259
Joined: Thu May 07, 2015 8:42 am
Contact:

Re: [0.16.X] Biters randomly destroying power poles

Post by Oxyd » Thu Mar 01, 2018 3:29 pm

The last guy gets stuck on the pole, but he goes from “everything's fine” to “I'm stuck” a little bit too fast. I increased the tolerance for getting stuck and now they all walk around the pole just fine.

Fixed in 0.16.28.

Absolute
Manual Inserter
Manual Inserter
Posts: 4
Joined: Wed Dec 09, 2015 9:18 am
Contact:

Re: [0.16.X] Biters randomly destroying power poles

Post by Absolute » Sat Mar 10, 2018 2:31 pm

Yes, also started losing my power poles in 0.16.27
But this isue wasn't presented several versions before, which is strange. Looks like it was caused by some recent updates, hopefuly the problem doesn't lie deeper.

Zylann
Manual Inserter
Manual Inserter
Posts: 1
Joined: Mon Apr 23, 2018 6:31 pm
Contact:

Re: [0.16.X] Biters randomly destroying power poles

Post by Zylann » Mon Apr 23, 2018 10:45 pm

I am getting the exact same issue, but my version came after the mentionned fix. Biters still destroy my poles from time to time, in Factorio 0.16.36. I tried to get a save to reproduce it but failed so far, many factors going on probably.
I managed to record a video though: https://www.youtube.com/watch?v=3q3Cgzle_I4
At 00:28, a biter within a swarm gets close to a pole and ends up destroying it. It looks like it gets blocked just because of its peers, otherwise there is nothing else around the pole. Would this be considered the same bug, or do I have to deal with it?
Due to this, for now I have to use workarounds such as setting up accumulators in all my outposts, be ready to replace the pole asap and add redundancy.

Post Reply

Return to “Resolved Problems and Bugs”

Who is online

Users browsing this forum: No registered users