[wheybags] [0.16.25] Crash when removing a chain signal

This subforum contains all the issues which we already resolved.
Post Reply
dmeranda
Burner Inserter
Burner Inserter
Posts: 5
Joined: Wed Apr 26, 2017 4:50 am
Contact:

[wheybags] [0.16.25] Crash when removing a chain signal

Post by dmeranda » Sat Feb 24, 2018 12:05 am

I have repeatedly caused the game to crash when removing a chain signal just seconds before a train passes through.

This is single-player under Linux with Factorio 0.6.25, pure vanilla, no mods installed.

Perhaps notable, or not, this was the very first 20 seconds of game play I did after upgrading from 0.6.24 to 0.6.25.

Starting from a save game, I performed the following steps as shown in the attached screenshots.

1. Create a small segment of track which merges two lines.
2. Add a new chain signal just before the merge point
3. Remove the old existing chain signal which is just after where the merge point was; results in immediate crash.

This crash only seems to happen if the above steps were performed fairly quickly (10-15 seconds?), and I believe it may have something to do with a train which passes by the signals in question. If the signal is removed after that it doesn't crash.
Attachments
factorio-crash2.log
Another crash log file, slightly different stack trace; same player actions
(14.25 KiB) Downloaded 52 times
crashable1.zip
Game save file
(36.52 MiB) Downloaded 45 times
factorio-crash.log
Saved factorio log file from crash
(7.64 KiB) Downloaded 54 times
factorio_crash_2018-02-23_snap_3.png
Snapshot step 3: old chain signal to be removed, immediately crashes
factorio_crash_2018-02-23_snap_3.png (1.48 MiB) Viewed 982 times
factorio_crash_2018-02-23_snap_2.png
Snapshot step 2: track and new chain signal added
factorio_crash_2018-02-23_snap_2.png (1.45 MiB) Viewed 982 times
factorio_crash_2018-02-23_snap_1.png
Snapshot, step 1: initial game same state
factorio_crash_2018-02-23_snap_1.png (1.45 MiB) Viewed 982 times

User avatar
wheybags
Factorio Staff
Factorio Staff
Posts: 283
Joined: Fri Jun 02, 2017 1:50 pm
Contact:

Re: [wheybags] [0.16.25] Crash when removing a chain signal

Post by wheybags » Fri Mar 02, 2018 10:33 am

Fixed for 0.16.28.
Thanks for the report!

Post Reply

Return to “Resolved Problems and Bugs”

Who is online

Users browsing this forum: No registered users