[16.25] Buffer chest receiving wrong items upon filter copy

This subforum contains all the issues which we already resolved.
Post Reply
Zanostra
Long Handed Inserter
Long Handed Inserter
Posts: 60
Joined: Mon Apr 03, 2017 8:03 pm
Contact:

[16.25] Buffer chest receiving wrong items upon filter copy

Post by Zanostra » Thu Feb 22, 2018 5:17 pm

ok, I had this logistic system with 8 buffer chests in it requesting copper ore.
when i build furnaces elsewhere I changed the station for ore to plates and the buffer chests too.
I did not delete them, I changed the request in one of them to request copper plates, and copy/pasted that to the other 7 buffers.
all went wel, but some copper ore came with me back to this logistic system and those 8 buffer chests still requested the ore.
Yet, they do not request the copper ore when provided into the system by a passive or storage chest.
But they still do when the copper ore is forced into the system by the player trash slots or an active provider chest.
Then the ores are not put into a free storage chest, but in the buffer chest with the last known copper ore request, even though they do not now.
Deleting the buffers and recreating them solves it, but I had to find out by production lacking copper plates.

I added the save file to this post.

greets ~Zanostra~
Attachments
buffer chest bug.zip
save file
(12.78 MiB) Downloaded 20 times

Loewchen
Global Moderator
Global Moderator
Posts: 5213
Joined: Wed Jan 07, 2015 5:53 pm
Contact:

Re: buffer chest receiving wrong items

Post by Loewchen » Thu Feb 22, 2018 5:31 pm

Can not reproduce, when I load this without mods no copper ore is delivered to buffer chests.
Can you reproduce this without mods?

Zanostra
Long Handed Inserter
Long Handed Inserter
Posts: 60
Joined: Mon Apr 03, 2017 8:03 pm
Contact:

Re: buffer chest receiving wrong items

Post by Zanostra » Thu Feb 22, 2018 6:59 pm

yes, I can. ( took a little time )
I don't know what exactly happened, but I know that I copy/pasted some of the requests of these buffer chests.
I made a vanilla sandbox game and in this savegame you can see that indeed the chests to the right request copper instead of metal.
If the savegame is not enough and you want me to send a log file or so, you would have to let me know how to find or make logfiles :)
Attachments
buffer chest bug sandbox.zip
(3.52 MiB) Downloaded 20 times

Rseding91
Factorio Staff
Factorio Staff
Posts: 9478
Joined: Wed Jun 11, 2014 5:23 am
Contact:

Re: buffer chest receiving wrong items

Post by Rseding91 » Thu Feb 22, 2018 7:18 pm

Zanostra wrote:yes, I can. ( took a little time )
I don't know what exactly happened, but I know that I copy/pasted some of the requests of these buffer chests.
I made a vanilla sandbox game and in this savegame you can see that indeed the chests to the right request copper instead of metal.
If the savegame is not enough and you want me to send a log file or so, you would have to let me know how to find or make logfiles :)
It looks like you simply requested copper for a moment and the robots started fulfilling the order then changed it to iron.
If you want to get ahold of me I'm almost always on Discord.

Zanostra
Long Handed Inserter
Long Handed Inserter
Posts: 60
Joined: Mon Apr 03, 2017 8:03 pm
Contact:

Re: buffer chest receiving wrong items

Post by Zanostra » Thu Feb 22, 2018 7:27 pm

no,
I just updated factorio and loaded this savefile myself again, and I noticed that after loading the bug was gone,
but again reproducible.
- load game
- left click one of the buffer chests
- change 100 metal to 100 copper
- use shift + mouse to copy/paste to all of the buffer chests
- change the reqester to active provider by placing on top of it ( no deletion first )
now all the metal will be requested bij a copper buffer chest, and just to be sure:
- build a requester chest and open it.
- let it request from buffer chests too and request tons of copper.
now all the copper filters out into that chest and the metal stays behind, still being requested by the buffer chests.
I left it going for over 5 minutes now, now way the robots are still busy with the same order, they keep asking for new.

Loewchen
Global Moderator
Global Moderator
Posts: 5213
Joined: Wed Jan 07, 2015 5:53 pm
Contact:

Re: buffer chest receiving wrong items

Post by Loewchen » Thu Feb 22, 2018 7:48 pm

Zanostra wrote:no,
I just updated factorio and loaded this savefile myself again, and I noticed that after loading the bug was gone,
but again reproducible.
- load game
- left click one of the buffer chests
- change 100 metal to 100 copper
- use shift + mouse to copy/paste to all of the buffer chests
- change the reqester to active provider by placing on top of it ( no deletion first )
now all the metal will be requested bij a copper buffer chest, and just to be sure:
- build a requester chest and open it.
- let it request from buffer chests too and request tons of copper.
now all the copper filters out into that chest and the metal stays behind, still being requested by the buffer chests.
I left it going for over 5 minutes now, now way the robots are still busy with the same order, they keep asking for new.
I can reproduce this with 16.25. I don't understand why there are not dozens of instant desync server around.

Rseding91
Factorio Staff
Factorio Staff
Posts: 9478
Joined: Wed Jun 11, 2014 5:23 am
Contact:

Re: [16.25] Buffer chest receiving wrong items upon filter copy

Post by Rseding91 » Fri Feb 23, 2018 2:34 pm

I still can't reproduce any kind of issue.

Can you make a video showing what problem you're having?
If you want to get ahold of me I'm almost always on Discord.

Zanostra
Long Handed Inserter
Long Handed Inserter
Posts: 60
Joined: Mon Apr 03, 2017 8:03 pm
Contact:

Re: [16.25] Buffer chest receiving wrong items upon filter copy

Post by Zanostra » Fri Feb 23, 2018 4:14 pm


Rseding91
Factorio Staff
Factorio Staff
Posts: 9478
Joined: Wed Jun 11, 2014 5:23 am
Contact:

Re: [16.25] Buffer chest receiving wrong items upon filter copy

Post by Rseding91 » Fri Feb 23, 2018 6:23 pm

Thanks for the video. I was able to reproduce it and it's now fixed for the next version of 0.16.
If you want to get ahold of me I'm almost always on Discord.

Post Reply

Return to “Resolved Problems and Bugs”

Who is online

Users browsing this forum: No registered users