[Twinsen][0.16.25] force.set_turret_attack_modifier() not reflected in bonuses

This subforum contains all the issues which we already resolved.
Post Reply
Mylon
Filter Inserter
Filter Inserter
Posts: 368
Joined: Sun Oct 23, 2016 11:42 pm
Contact:

[Twinsen][0.16.25] force.set_turret_attack_modifier() not reflected in bonuses

Post by Mylon » Sun Feb 18, 2018 6:42 pm

The mod I'm working on uses set_turret_attack_modifier to change turret damage. In the team bonus screen, the mouseover tooltip shows the turret damage from the ammo damage modifier, but not the turret damage modifier.

In the attached screenshot in the background, you can see laser turrets have a -66% modifier, but the tooltip does not reflect this. In the turret-entity description, the number is different and does include the turret attack modifier.

Image
  • Different but related bugs
  • If the damage modifier makes the damage "bonus" negative, it displays in the description as +- value.
  • Artillery turrets are not listed in the force bonus screen

Twinsen
Factorio Staff
Factorio Staff
Posts: 970
Joined: Tue Sep 23, 2014 7:10 am
Contact:

Re: [Twinsen][0.16.25] force.set_turret_attack_modifier() not reflected in bonuses

Post by Twinsen » Fri Mar 09, 2018 1:55 pm

Thanks for the report.
Fixed a number of inconsistencies between damage bonus in item tootltip vs entity tooltip.

Also Rseding is looking into the other 2 issues.

Fixed in Version: 0.16.29

Post Reply

Return to “Resolved Problems and Bugs”

Who is online

Users browsing this forum: No registered users