[wheybags] [0.16.22] Odd train behavior and desync

This subforum contains all the issues which we already resolved.
Post Reply
porksmash
Burner Inserter
Burner Inserter
Posts: 5
Joined: Wed Feb 22, 2017 4:11 am
Contact:

[wheybags] [0.16.22] Odd train behavior and desync

Post by porksmash » Sun Feb 11, 2018 11:02 pm

A buddy was messing around with trains and created a rail setup that causes the train to stutter forward (similar to this issue) until it eventually no-paths, stops, and then moves forward normally. It loops back around to the bottom station and repeats. This eventually caused a permanent desync on the server and nobody was able to log into the game. We were able to isolate the setup that caused the issue and recreate the desync in a brand new map with only a few rails and stations, which is the desync report I attached. If you would like the first desync report in our actual map, I can attach it as well. We thought it was odd that the train stuttering only happens on one particular station in the loop, when they are all set up identically.
Attachments
desync-report-2018-02-11_14-35-54.zip
(11.87 MiB) Downloaded 34 times

Loewchen
Global Moderator
Global Moderator
Posts: 5213
Joined: Wed Jan 07, 2015 5:53 pm
Contact:

Re: [0.16.22] Odd train behavior and desync

Post by Loewchen » Sun Feb 11, 2018 11:15 pm

Are you using mods or a custom scenario?

porksmash
Burner Inserter
Burner Inserter
Posts: 5
Joined: Wed Feb 22, 2017 4:11 am
Contact:

Re: [0.16.22] Odd train behavior and desync

Post by porksmash » Sun Feb 11, 2018 11:19 pm

I used creative mod in single player to set up the map in the desync report, but loaded into a server with no mods or custom scenarios in order to create the desync

User avatar
wheybags
Factorio Staff
Factorio Staff
Posts: 258
Joined: Fri Jun 02, 2017 1:50 pm
Contact:

Re: [wheybags] [0.16.22] Odd train behavior and desync

Post by wheybags » Tue Feb 13, 2018 4:24 pm

I couldn't reproduce the desync, but I have fixed the train stuttering.
Is it enough to just start a server, then connect to that server with one client and wait? How long does it take for you before it desyncs?

Rseding91
Factorio Staff
Factorio Staff
Posts: 9481
Joined: Wed Jun 11, 2014 5:23 am
Contact:

Re: [wheybags] [0.16.22] Odd train behavior and desync

Post by Rseding91 » Tue Feb 13, 2018 9:48 pm

wheybags wrote:I couldn't reproduce the desync, but I have fixed the train stuttering.
Is it enough to just start a server, then connect to that server with one client and wait? How long does it take for you before it desyncs?
I tried to reproduce the desync my self the other day when this was first reported and couldn't. I ran the save for 5 minutes in heavy mode and it had no problems.
If you want to get ahold of me I'm almost always on Discord.

porksmash
Burner Inserter
Burner Inserter
Posts: 5
Joined: Wed Feb 22, 2017 4:11 am
Contact:

Re: [wheybags] [0.16.22] Odd train behavior and desync

Post by porksmash » Wed Feb 14, 2018 3:42 am

On the demo map in desync report my buddy triggered the desync by running in front of the train after it hit the no path and resumed, while I stood watching. From my POV he didn't move, just desynced and got booted offline. I did not desync and stayed in game. I'll see if I can reproduce again.

porksmash
Burner Inserter
Burner Inserter
Posts: 5
Joined: Wed Feb 22, 2017 4:11 am
Contact:

Re: [wheybags] [0.16.22] Odd train behavior and desync

Post by porksmash » Wed Feb 14, 2018 4:51 am

Well we spent about 30 minutes trying to recreate it and failed, both on the demo map and our actual save. I can provide the original desync report on the large map, but it is too large to attach. Do you need it?

User avatar
wheybags
Factorio Staff
Factorio Staff
Posts: 258
Joined: Fri Jun 02, 2017 1:50 pm
Contact:

Re: [wheybags] [0.16.22] Odd train behavior and desync

Post by wheybags » Wed Feb 14, 2018 2:09 pm

I think it's fine, let us know if you can reproduce it again in 0.16.24 once it's released.
Thanks for the report!

Post Reply

Return to “Resolved Problems and Bugs”

Who is online

Users browsing this forum: No registered users