[0.16.26] Negative energy consumption, accumulators not used

This subforum contains all the issues which we already resolved.
Post Reply
wvlad
Fast Inserter
Fast Inserter
Posts: 215
Joined: Thu Jul 13, 2017 9:55 pm
Contact:

[0.16.26] Negative energy consumption, accumulators not used

Post by wvlad »

Last edited by wvlad on Thu Mar 01, 2018 3:33 pm, edited 2 times in total.

User avatar
impetus maximus
Smart Inserter
Smart Inserter
Posts: 1299
Joined: Sat Aug 20, 2016 10:07 pm
Contact:

Re: [0.16.22] Negative energy consumption, accumulators not used

Post by impetus maximus »

if consumption is negative, why would you expect them to be used? :?

wvlad
Fast Inserter
Fast Inserter
Posts: 215
Joined: Thu Jul 13, 2017 9:55 pm
Contact:

Re: [0.16.22] Negative energy consumption, accumulators not used

Post by wvlad »

I mean that red bar on screenshot going left. Something is really broken there.

Rseding91
Factorio Staff
Factorio Staff
Posts: 10978
Joined: Wed Jun 11, 2014 5:23 am
Contact:

Re: [0.16.22] Negative energy consumption, accumulators not used

Post by Rseding91 »

Can you please upload the mods you're using as well?
If you want to get ahold of me I'm almost always on Discord.

wvlad
Fast Inserter
Fast Inserter
Posts: 215
Joined: Thu Jul 13, 2017 9:55 pm
Contact:

Re: [0.16.22] Negative energy consumption, accumulators not used

Post by wvlad »

Uploaded except music and alien biomes.
https://www.dropbox.com/s/xm9qq44dvmc97 ... s.zip?dl=1

Rseding91
Factorio Staff
Factorio Staff
Posts: 10978
Joined: Wed Jun 11, 2014 5:23 am
Contact:

Re: [0.16.22] Negative energy consumption, accumulators not used

Post by Rseding91 »

I can't reproduce what you're seeing. When I load the game energy consumption is normal.
If you want to get ahold of me I'm almost always on Discord.

wvlad
Fast Inserter
Fast Inserter
Posts: 215
Joined: Thu Jul 13, 2017 9:55 pm
Contact:

Re: [0.16.22] Negative energy consumption, accumulators not used

Post by wvlad »

Sorry, I can't reproduce it now either. It's possible that it was caused by some kind of memory corruption and fixed itself after restart.

wvlad
Fast Inserter
Fast Inserter
Posts: 215
Joined: Thu Jul 13, 2017 9:55 pm
Contact:

Re: [0.16.22] Negative energy consumption, accumulators not used

Post by wvlad »

I was able to reproduce it again in 0.16.26.
Save: https://www.dropbox.com/s/t1s1qp15hqr04 ... 1.zip?dl=1
Mods: https://www.dropbox.com/s/6lu0qxdmrjkxi ... 0.zip?dl=1

It's caused by the Suit-Plug mod. Look at the accumulator charge.

Image

wvlad
Fast Inserter
Fast Inserter
Posts: 215
Joined: Thu Jul 13, 2017 9:55 pm
Contact:

Re: [0.16.22] Negative energy consumption, accumulators not used

Post by wvlad »

Apparently, it happens when you directly subtract energy from accumulator faster than its output flow limit allows.

Rseding91
Factorio Staff
Factorio Staff
Posts: 10978
Joined: Wed Jun 11, 2014 5:23 am
Contact:

Re: [0.16.22] Negative energy consumption, accumulators not used

Post by Rseding91 »

wvlad wrote:Apparently, it happens when you directly subtract energy from accumulator faster than its output flow limit allows.
Ok, it's now fixed for the next version of 0.16.
If you want to get ahold of me I'm almost always on Discord.

Post Reply

Return to “Resolved Problems and Bugs”

Who is online

Users browsing this forum: No registered users