[Rseding91][0.16.20][Modding] on_create_entity over ghosts

This subforum contains all the issues which we already resolved.
Post Reply
User avatar
lovely_santa
Fast Inserter
Fast Inserter
Posts: 151
Joined: Sat Feb 18, 2017 9:41 pm
Contact:

[Rseding91][0.16.20][Modding] on_create_entity over ghosts

Post by lovely_santa » Sat Jan 27, 2018 12:56 pm

Hi,

When I got a line of walls they all connect just fine...
2018-01-27_134306.png
2018-01-27_134306.png (349.03 KiB) Viewed 710 times
Then I throw some grenades to destroy them, and there ghost appear to reconstruct them...
2018-01-27_134548.png
2018-01-27_134548.png (459.7 KiB) Viewed 710 times
The fields will be automaticly get replaced (can_place_entity and create_entity) over the ghosts (fixed in 0.16.17 release).
In this version (0.16.20, dunno if this happens in 18,19) the walls don't connect between those that where there already and those replaced over ghosts. This doesn't happen for walls that get replaced without a ghost underneath. (for example when mining a wall)
2018-01-27_134702.png
2018-01-27_134702.png (304.5 KiB) Viewed 710 times
As you see, the walls that had the ghost under id will be created seperatly and not connect to those that wheren't destroyed.
When manualy removing (by mining) one of the two walls that is not connected, it will recreate that wall (without the ghost under it) and it will be connected again.

This same behaviour happens on connections between wall/gates.
2018-01-27_135756.png
2018-01-27_135756.png (295.85 KiB) Viewed 709 times

I've added this save file (in the state that the walls don't connect)
Also included the (only) mod used (unreleased version).

Greetings,
lovely_santa
Attachments
ForceFields2_2.0.4.zip
Mod used in the savegame
(1.81 MiB) Downloaded 26 times
savegame.zip
saved game in the state of unconnected walls
(4.17 MiB) Downloaded 26 times
You can find all my mods on the mod portal.
Image

Rseding91
Factorio Staff
Factorio Staff
Posts: 9471
Joined: Wed Jun 11, 2014 5:23 am
Contact:

Re: [Rseding91][0.16.20][Modding] on_create_entity over ghosts

Post by Rseding91 » Sun Jan 28, 2018 12:01 am

Thanks for the report. It's now fixed for the next version of 0.16.
If you want to get ahold of me I'm almost always on Discord.

Post Reply

Return to “Resolved Problems and Bugs”

Who is online

Users browsing this forum: No registered users