[0.16.16] Pump ignores fluidbox filter.

This subforum contains all the issues which we already resolved.
Post Reply
User avatar
eradicator
Smart Inserter
Smart Inserter
Posts: 3175
Joined: Tue Jul 12, 2016 9:03 am
Contact:

[0.16.16] Pump ignores fluidbox filter.

Post by eradicator » Tue Jan 16, 2018 7:52 pm

Setting a filter on the fluidbox of a pump (not offshore-pump) via API suggests that setting the filter works (i.e. returns true) but the pump still pumps unfiltered fluids.

Code: Select all

/c game.print(serpent.line(game.player.selected.fluidbox.set_filter(1,{name='lubricant',force=true})))
--true
/c game.print(serpent.line(game.player.selected.fluidbox.get_filter(1)))
--{maximum_temperature = 100, minimum_temperature = 25, name = "lubricant"}
/c game.print(serpent.line(game.player.selected.fluidbox[1]))
--{amount = 200, name = "heavy-oil", temperature = 25.000000000000501}
I tried setting the filter in various settings, on an empty pump, a newly build one and one that still contained old liquid, with or without force=true. but nothing works. It works fine on pipes/tanks. And on assemblers attempting to set a filter returns "false" as expected.

Expected behavior: The pump should only accept the filtered fluid :D.
Author of: Hand Crank Generator, Screenshot Hotkey 2.0
Mod support languages: 日本語, Deutsch, English
My code in the post above is dedicated to the public domain under CC0.

User avatar
bobingabout
Smart Inserter
Smart Inserter
Posts: 6728
Joined: Fri May 09, 2014 1:01 pm
Contact:

Re: [0.16.16] Pump ignores fluidbox filter.

Post by bobingabout » Wed Jan 17, 2018 8:56 am

I didn't even realise filter was run time editable, I thought it was something you set in the data phase.
Creator of Bob's mods. Expanding your gameplay since version 0.9.8.
I also have a Patreon.

Rseding91
Factorio Staff
Factorio Staff
Posts: 9453
Joined: Wed Jun 11, 2014 5:23 am
Contact:

Re: [0.16.16] Pump ignores fluidbox filter.

Post by Rseding91 » Thu Jan 25, 2018 5:41 am

Thanks for the report. This is now fixed for the next version of 0.16. thanks to Klonan.
If you want to get ahold of me I'm almost always on Discord.

Post Reply

Return to “Resolved Problems and Bugs”

Who is online

Users browsing this forum: No registered users