[Rseding91] Inserters take wrong material from belt (for furnace)

This subforum contains all the issues which we already resolved.
Post Reply
nuhll
Filter Inserter
Filter Inserter
Posts: 820
Joined: Mon Apr 04, 2016 9:48 pm
Contact:

[Rseding91] Inserters take wrong material from belt (for furnace)

Post by nuhll » Wed Jan 03, 2018 11:33 pm

Hi,
ive been playin around with LTN and with a multi furnace setup, everything works perfect. Only one problem:

-Lets say Iron ore and Ironplates (Iron plates and Steal) are requestet... something stupid happens... some inerters take IRON ORE <EVEN> they have already IRON in the furnace. Normal behaivior would be to only put in what already in is. - As far as i know.



That would be (from my perspective, logic)

Lets Say you have coal and wood on belt, i guess the inserter would also take coal if coal is missing and wood if wood is missing, correct?!

Anyway, is there maybe a mod which change this behaivior?
Neue Bitmap.jpg
Neue Bitmap.jpg (3.76 MiB) Viewed 1501 times
Is this bug intented?

I think it should be:
If iron ore is inside the furnace, wait for iron ore.
If iron is in the furnace, wait for iron.

OR

Let us connect furnace to the inserter and "SET FILTER" (to whats already in furnace) [stupid fix if u ask me]

Rseding91
Factorio Staff
Factorio Staff
Posts: 9977
Joined: Wed Jun 11, 2014 5:23 am
Contact:

Re: [Rseding91] Inserters take wrong material from belt (for furnace)

Post by Rseding91 » Thu Jan 04, 2018 12:00 am

Thanks for the report. I changed it so inserters will never try to put items into the furnace when there's already a different item in the input slots.
If you want to get ahold of me I'm almost always on Discord.

nuhll
Filter Inserter
Filter Inserter
Posts: 820
Joined: Mon Apr 04, 2016 9:48 pm
Contact:

Re: [Rseding91] Inserters take wrong material from belt (for furnace)

Post by nuhll » Thu Jan 04, 2018 12:09 am

WTF, so fast?

When i can try it? :D

Thanks for your work. Nearly 1000h with factorio. Best buy in my life.

Easy all one smelter incoming... :D

nuhll
Filter Inserter
Filter Inserter
Posts: 820
Joined: Mon Apr 04, 2016 9:48 pm
Contact:

Re: [Rseding91] Inserters take wrong material from belt (for furnace)

Post by nuhll » Thu Jan 04, 2018 6:24 pm

Just to be sure, is that fixed in 0.16.13? If not, when comes the next patch? Cant wait for it!

pingger
Inserter
Inserter
Posts: 29
Joined: Fri Dec 26, 2014 2:47 pm
Contact:

Re: [Rseding91] Inserters take wrong material from belt (for furnace)

Post by pingger » Thu Jan 04, 2018 9:59 pm

Is fixed in the 0.16.14. Which can be downloaded since a few minutes.

nuhll
Filter Inserter
Filter Inserter
Posts: 820
Joined: Mon Apr 04, 2016 9:48 pm
Contact:

Re: [Rseding91] Inserters take wrong material from belt (for furnace)

Post by nuhll » Thu Jan 04, 2018 10:07 pm

omfg so great. Thanks.

Epicnoob
Burner Inserter
Burner Inserter
Posts: 12
Joined: Sun Jul 03, 2016 6:56 pm
Contact:

Re: [Rseding91] Inserters take wrong material from belt (for furnace)

Post by Epicnoob » Fri Jan 05, 2018 4:03 pm

I actually ran into this kind of behavior when using a single belt for iron ore input and iron plate output. I didn't care whether the ore was smelted to iron or steel, but I did get annoyed when the furnaces got stuck. Now I could actually make a mixed smelting setup capable of smelting stone and other types of ore without it trying to put in copper in a furnace thats trying to smelt stone.

While annoying, I didn't actually consider reporting it as a bug.

nuhll
Filter Inserter
Filter Inserter
Posts: 820
Joined: Mon Apr 04, 2016 9:48 pm
Contact:

Re: [Rseding91] Inserters take wrong material from belt (for furnace)

Post by nuhll » Fri Jan 05, 2018 10:43 pm

I now just combined all smelting, except steel, bc after time too much get stuck and u need more iron and copper then steel, so its not worth.

But stil better then for every thing extra smelting.

Post Reply

Return to “Resolved Problems and Bugs”

Who is online

Users browsing this forum: No registered users