[kovarex] [0.16.12] Crash using decon planner in strange circumstances

This subforum contains all the issues which we already resolved.
Post Reply
AndreasTPC
Manual Inserter
Manual Inserter
Posts: 3
Joined: Wed Dec 13, 2017 2:36 pm
Contact:

[kovarex] [0.16.12] Crash using decon planner in strange circumstances

Post by AndreasTPC » Wed Jan 03, 2018 3:58 pm

Background info:

I'm using this mod, which I believe is related: https://mods.factorio.com/mods/daniel34 ... p-autohide

I'm using the Linux version, I don't know if it's possible to reproduce with the builds for the other operating systems.

When I was playing today my toolbar disappeared from the ui. I remember that this mod had a keyboard shortcut to show and hide it, and figured that I had hit it accidentally. I tried using it to get it to re-appear again, but the keyboard shortcut did nothing. I checked out the mod source code and found the console command that should enable/disable it, game.player.game_view_settings.show_controller_gui = true, but running that manually didn't do anything either. I also tried that on a separate save (where the toolbar was still visible) and was unable to hide the toolbar by setting that to false. It's in the api docs, so the fact that it didn't work might be a separate bug (should I make another thread?), and how I managed to get the game to hide it in the first place is a mystery to me. I have not tested if it works or not on a clean install without mods.

Crash details:

Now for the crash. If I load up the latest save, which I made after the toolbar had disappeared, it's still not there. When I load the save the overlay showing roboport connections are visible. This is because when I made the save I had a deconstrution planner in my hand. That took me a while to figure out, because the mouse cursor icon for the deconstruction planner isn't visible either. Either way, when I click on anything with this deconstruction planner the game crashes.

The moment of the crash the game seems to freeze up, and then it takes 10-15 seconds before the process actually dies. During this time my computer becomes generally unresponsive if I try to switch over to another program. This is just speculation on my part, but maybe the game starts allocating large amounts of memory for some reason, and after ~10-15 seconds the system runs out of ram, causing the linux kernel's out-of-memory process killer to step in and kill it?

Reproducing:

The crash seems to be reproducible every time for me, I can just load the save, and click on anything with the (invisible) decon planner that is already in my hand, and it crashes. If I press q to get rid of it before clicking on anything the crash doesn't happen.

Stack trace:

Code: Select all

 139.807 Warning Logger.cpp:446: Symbols.size() == 15, usedSize == 13
Factorio crashed. Generating symbolized stacktrace, please wait ...
 153.329 Warning Logger.cpp:446: Symbols.size() == 14, usedSize == 12
#0  0x000000000067e1f7 in CrashHandler::writeStackTrace(CrashHandler::CrashReason) at /tmp/factorio-gfNsuB/src/Util/CrashHandler.cpp:127
#1  0x000000000067e40a in CrashHandler::SignalHandler(int) at /tmp/factorio-gfNsuB/src/Util/CrashHandler.cpp:421
#2  0x0000000000033af0 in ?? at ??:0
#3  0x0000000000962fa0 in GameView::getQuickbarWidget() at /tmp/factorio-gfNsuB/src/GameView.cpp:177
#4  0x0000000000bb4f51 in InputHandlerAllegro::sendSelectionChanges() at /tmp/factorio-gfNsuB/src/Input/InputHandlerAllegro.cpp:1244
#5  0x00000000009d0ee4 in InputHandlerAllegro::sendStateChanges() at /tmp/factorio-gfNsuB/src/Input/InputHandlerAllegro.cpp:936
#6  0x0000000000c2e248 in GameActionHandler::update() at /tmp/factorio-gfNsuB/src/GameActionHandler.cpp:304
#7  0x0000000000c2ed9f in MainLoop::gameUpdateStep(MultiplayerManagerBase*, Scenario*, AppManager*, MainLoop::HeavyMode) at /tmp/factorio-gfNsuB/src/MainLoop.cpp:979
#8  0x000000000067f665 in MainLoop::gameUpdateLoop(MainLoop::HeavyMode) at /tmp/factorio-gfNsuB/src/MainLoop.cpp:852
#9  0x000000000149f20f in std::function<void ()>::operator=(decltype(nullptr)) at /usr/include/c++/7/bits/std_function.h:514
#10 0x0000000000007519 in WorkerThread::loop() at /tmp/factorio-gfNsuB/src/Util/WorkerThread.cpp:36
#11 (nil) in execute_native_thread_routine at jidctflt.c:?
 153.378 Error CrashHandler.cpp:128: Map tick at moment of crash: 19267579
 153.378 Error Util.cpp:67: Unexpected error occurred. If you're running the latest version of the game you can help us solve the problem by posting the contents of the log file on the Factorio forums.
Please also include the save file(s), any mods you may be using, and any steps you know of to reproduce the crash.
Attachments:

Save file and log is attached. I am unable to attach the zipped up mods, the forum won't let me, it's complaining about the file size being too large, so I uploaded it to a file hosting site instead, and you can find it here: https://nofile.io/f/XAOaaDhoy6B/mods.zip (I don't know how reliable this site is)

Let me know if you need anything else.
Attachments
save.zip
(13.32 MiB) Downloaded 17 times
factorio-current.log
(269.95 KiB) Downloaded 16 times

kovarex
Factorio Staff
Factorio Staff
Posts: 7362
Joined: Wed Feb 06, 2013 12:00 am
Contact:

Re: [kovarex] [0.16.12] Crash using decon planner in strange circumstances

Post by kovarex » Wed Jan 03, 2018 6:43 pm

Fixed for the next release (both issues of not updating the controller view settings until reload and the crash).

Thanks for the report.

Post Reply

Return to “Resolved Problems and Bugs”

Who is online

Users browsing this forum: No registered users