[Rseding91] [0.16.6] Endless "Ok" loop if scenario has invalid argument

This subforum contains all the issues which we already resolved.
Post Reply
Sergeant_Steve
Inserter
Inserter
Posts: 21
Joined: Tue Jun 28, 2016 10:24 pm
Contact:

[Rseding91] [0.16.6] Endless "Ok" loop if scenario has invalid argument

Post by Sergeant_Steve » Thu Dec 21, 2017 12:08 am

I'm trying to put together a custom scenario for the fMMO Admin tools to see if there is one module in particular that is causing the desyncs, and I forgot to check what was set in control.lua and ended up with two sets of admin tools enabled.

Which then led to admin.lua having an invalid argument on line 64 (which I'm not worried about because we're using more modular ones now), however from the "Generate Preview" Screen when I clicked Play all Factorio does is keep telling me about the invalid argument and all I can do is repeatedly click "Ok".

There is no timeout or retry limit and I had to Alt-F4 to escape it, as even when the error box disappeared for a couple of seconds I wasn't able to click on any other buttons.

I've uploaded the scenario as it was when I went to generate a map from it.
FMMO-0.16 Admin Tools.zip
The scenario for you to test for yourself.
(46.18 KiB) Downloaded 27 times

Rseding91
Factorio Staff
Factorio Staff
Posts: 9478
Joined: Wed Jun 11, 2014 5:23 am
Contact:

Re: [Rseding91] [0.16.6] Endless "Ok" loop if scenario has invalid argument

Post by Rseding91 » Thu Dec 21, 2017 12:16 am

Thanks for the report. This is now fixed for the next version of 0.16.
If you want to get ahold of me I'm almost always on Discord.

Post Reply

Return to “Resolved Problems and Bugs”

Who is online

Users browsing this forum: No registered users