[Rseding91] [0.16.6] Roboports' repair packs on 0.15 -> 0.16 save

This subforum contains all the issues which we already resolved.
Post Reply
Ethenen
Manual Inserter
Manual Inserter
Posts: 1
Joined: Mon Dec 18, 2017 6:11 pm
Contact:

[Rseding91] [0.16.6] Roboports' repair packs on 0.15 -> 0.16 save

Post by Ethenen » Tue Dec 19, 2017 2:18 pm

0.16 brought this:
"Roboports now provide the repair packs they have for other robots to use."

That doesn't seem to work on save migrated from 0.15 (tested on 0.15.40 save, save included). From my testing it looks like roboports placed in 0.15 will not be able to provide repair packs inside them to c.robots in the network when the map gets opened in 0.16 (issue noticed in 0.16.5).
The workaround right now is to remove the roboports placed before 0.16 and place them again while playing in 0.16 .

About the save:
- left roboport has repair packs inside, right one has robots
- save is from 0.15.40
- if you open the save in current version (0.16.6) and damage any of the solar panels, nothing will happen
- remove left roboport, place it again and put repair packs inside
- robots from right roboport will be able to 'see' them and fly for them to then use them to repair damaged solar panels.
Attachments
achievs.zip
0.15.40 save
(1.86 MiB) Downloaded 24 times

Rseding91
Factorio Staff
Factorio Staff
Posts: 9856
Joined: Wed Jun 11, 2014 5:23 am
Contact:

Re: [Rseding91] [0.16.6] Roboports' repair packs on 0.15 -> 0.16 save

Post by Rseding91 » Wed Dec 20, 2017 9:12 pm

Thanks for the report. I've fixed it for the next version of 0.16 so loading 0.15 saves will migrate them correctly. Saves already in 0.16 from 0.15 will still be broken.
If you want to get ahold of me I'm almost always on Discord.

Post Reply

Return to “Resolved Problems and Bugs”

Who is online

Users browsing this forum: No registered users