[0.16.6] [Linux] Binary not marked as executable

This subforum contains all the issues which we already resolved.
Post Reply
Daeruun
Burner Inserter
Burner Inserter
Posts: 16
Joined: Thu May 04, 2017 8:37 pm
Contact:

[0.16.6] [Linux] Binary not marked as executable

Post by Daeruun » Mon Dec 18, 2017 7:44 pm

Hi folks,

after I just noticed the release of 0.16.6 I updated my headless server.
Unfortunately the binary is still not marked executable, although otherwise stated in [16.2][mac] Executable not declared as such after update.

after chmod +x it works correctly.

Loewchen
Global Moderator
Global Moderator
Posts: 5213
Joined: Wed Jan 07, 2015 5:53 pm
Contact:

Re: [0.16.6] [Linux] Binary not marked as executable

Post by Loewchen » Mon Dec 18, 2017 7:49 pm

The report you reference describes a mac issue only I believe. Post your log after a session with the issue please.

Daeruun
Burner Inserter
Burner Inserter
Posts: 16
Joined: Thu May 04, 2017 8:37 pm
Contact:

Re: [0.16.6] [Linux] Binary not marked as executable

Post by Daeruun » Mon Dec 18, 2017 8:09 pm

Thanks for acknowledging, Löwchen.
I thought Hanzi noticed Zarklord's post after yours.

log of update:
factorio-previous.log
(1.35 KiB) Downloaded 28 times
putty-session:
update_putty.png
update_putty.png (74.88 KiB) Viewed 787 times

Loewchen
Global Moderator
Global Moderator
Posts: 5213
Joined: Wed Jan 07, 2015 5:53 pm
Contact:

Re: [0.16.6] [Linux] Binary not marked as executable

Post by Loewchen » Mon Dec 18, 2017 8:20 pm

Daeruun wrote:I thought Hanzi noticed Zarklord's post after yours.
Indeed, I did not see that one.

User avatar
HanziQ
Former Staff
Former Staff
Posts: 630
Joined: Fri Mar 27, 2015 7:07 am
Contact:

Re: [0.16.6] [Linux] Binary not marked as executable

Post by HanziQ » Tue Dec 19, 2017 11:50 am

Ah, I see, this is a separate issue, --apply-update is broken too. I will fix it for 0.16.7 and maybe redo the 0.15.40 -> 0.16.7 updates to hide the bug.

Post Reply

Return to “Resolved Problems and Bugs”

Who is online

Users browsing this forum: Google [Bot]