[0.16.4]Broken map gen at x -22000

This subforum contains all the issues which we already resolved.
Post Reply
Bilka
Factorio Staff
Factorio Staff
Posts: 1928
Joined: Sat Aug 13, 2016 9:20 am
Contact:

[0.16.4]Broken map gen at x -22000

Post by Bilka » Mon Dec 18, 2017 4:07 pm

I travelled to x -22000 and y 13000 only to be met with broken map gen: Image.
The map was created in 0.16.4 and never opened in another version. Here is the save: https://drive.google.com/file/d/1W65xtA ... sp=sharing . Player Bilka is in the spot where the map gen is obviously broken.
I'm an admin over at https://wiki.factorio.com. Feel free to contact me if there's anything wrong (or right) with it.

orzelek
Smart Inserter
Smart Inserter
Posts: 3574
Joined: Fri Apr 03, 2015 10:20 am
Contact:

Re: [0.16.4]Broken map gen at x -22000

Post by orzelek » Mon Dec 18, 2017 8:24 pm

You were to curious? ;)

Ayamari
Inserter
Inserter
Posts: 25
Joined: Sat Nov 12, 2016 10:51 am
Contact:

Re: [0.16.4]Broken map gen at x -22000

Post by Ayamari » Mon Dec 18, 2017 10:39 pm

I can reproduce the problem, but much earlier. Both freeplay and sandbox. At x <= -10'000 the map generator blows up with sharp vertical edges and artifacts.
Explored a sandbox map from -12'000 to +12'000 in both axes:
x <= -10'000 -> clearly visible artifacts
x >= +10'000 -> looks fine (tested up to +12'000)
y <= -10'000 -> looks fine (tested up to -12'000)
y >= +10'000 -> looks fine (tested up to +12'000)

Tested both 0.16.5 and 0.16.6. Both break at x <= -10'000.
Repro:
- start sandbox with default options
- scroll to approx. x = -10'000
- explore y +- 1'000 and x += 2'000
- notice sharp edges and artifacts

Tested 3 randomly generated sandbox maps, all had the problems visible within (-12'000, -1'000)->(-10'000, +1'000) area, so this is at least fairly reliable.

User avatar
TruePikachu
Filter Inserter
Filter Inserter
Posts: 865
Joined: Sat Apr 09, 2016 8:39 pm
Contact:

Re: [0.16.4]Broken map gen at x -22000

Post by TruePikachu » Tue Dec 19, 2017 10:16 pm

To confirm, the map generator was working fine this far away from spawn back in .15?

Rseding91
Factorio Staff
Factorio Staff
Posts: 9436
Joined: Wed Jun 11, 2014 5:23 am
Contact:

Re: [0.16.4]Broken map gen at x -22000

Post by Rseding91 » Wed Dec 20, 2017 3:49 am

TruePikachu wrote:To confirm, the map generator was working fine this far away from spawn back in .15?
I can confirm it worked perfectly in 0.15 right up to the artificial limit of +- 1 million.
If you want to get ahold of me I'm almost always on Discord.

lotzik
Burner Inserter
Burner Inserter
Posts: 13
Joined: Sun Jan 08, 2017 12:48 am
Contact:

Re: [0.16.4]Broken map gen at x -22000

Post by lotzik » Tue Dec 26, 2017 9:58 pm

this keeps happening in 0.16.7
Attachments
asdfr.JPG
asdfr.JPG (45.19 KiB) Viewed 1635 times

Rseding91
Factorio Staff
Factorio Staff
Posts: 9436
Joined: Wed Jun 11, 2014 5:23 am
Contact:

Re: [0.16.4]Broken map gen at x -22000

Post by Rseding91 » Wed Dec 27, 2017 2:57 am

lotzik wrote:this keeps happening in 0.16.7
Because it's resolved for the next release which isn't out yet.
If you want to get ahold of me I'm almost always on Discord.

Post Reply

Return to “Resolved Problems and Bugs”

Who is online

Users browsing this forum: No registered users