[0.16.3] Crash when hovering a blueprint

This subforum contains all the issues which we already resolved.
Post Reply
Tritano
Burner Inserter
Burner Inserter
Posts: 17
Joined: Tue Sep 22, 2015 5:12 pm
Contact:

[0.16.3] Crash when hovering a blueprint

Post by Tritano » Sat Dec 16, 2017 11:22 am

Factorio: 0.16.3
System: Ubuntu 17.10

I have a blueprint from 0.15 - a shopping mall.
When I hover this blueprint with the mouse the game crashes.
This does not happen for other blueprints.

Code: Select all

  84.484 Error CrashHandler.cpp:419: Received SIGSEGV
Factorio crashed. Generating symbolized stacktrace, please wait ...
  87.381 Warning Logger.cpp:446: Symbols.size() == 30, usedSize == 22
#0  0x0000000000b0b84d in Logger::logStacktrace(StackTraceInfo*) at /tmp/factorio-FlJt8n/src/Util/Logger.cpp:471
#1  0x0000000000688007 in CrashHandler::writeStackTrace(CrashHandler::CrashReason) at /tmp/factorio-FlJt8n/src/Util/CrashHandler.cpp:127
#2  0x000000000068821a in CrashHandler::SignalHandler(int) at /tmp/factorio-FlJt8n/src/Util/CrashHandler.cpp:421
#3  0x0000000000037140 in ?? at ??:0
#4  0x0000000000a51621 in MapPosition::MapPosition(MapPosition const&, Vector const&) at /tmp/factorio-FlJt8n/src/Util/MapPosition.cpp:116
#5  0x0000000000a53dc8 in CircuitConnector::drawConnections(DrawQueue&) const at /tmp/factorio-FlJt8n/src/CircuitNetwork/CircuitConnector.cpp:464
#6  0x0000000000a53edb in InserterControlBehavior::drawCustom(DrawQueue&, CircuitConnectorSprites const&) at /tmp/factorio-FlJt8n/src/CircuitNetwork/Behaviors/InserterControlBehavior.cpp:109
#7  0x00000000006d1a3c in Inserter::draw(DrawQueue&) const at /tmp/factorio-FlJt8n/src/Entity/Inserter.cpp:223
#8  0x00000000006d1bea in BlueprintEntities::drawEntity(DrawQueue&, Entity const*, ItemRequests const&, bool) at /tmp/factorio-FlJt8n/src/Blueprint/BlueprintEntities.cpp:908
#9  0x000000000097d87c in BlueprintEntities::draw(DrawQueue&) const at /tmp/factorio-FlJt8n/src/Blueprint/BlueprintEntities.cpp:666
#10 0x000000000097dd68 in Blueprint::getBuildingGridBitShift() const at /tmp/factorio-FlJt8n/src/Blueprint/Blueprint.cpp:291
#11 0x000000000097de20 in Blueprint::draw(DrawQueue&) const at /tmp/factorio-FlJt8n/src/Blueprint/Blueprint.cpp:506
#12 0x0000000000558bcd in BlueprintWidget::updateBlueprint(Blueprint const*) at /tmp/factorio-FlJt8n/src/Gui/BlueprintWidget.cpp:176
#13 0x0000000000fa3fff in BlueprintWidget::BlueprintWidget(Blueprint const&, GuiInfoProvider&, GuiActionHandler*, float) at /tmp/factorio-FlJt8n/src/Gui/BlueprintWidget.cpp:140
#14 0x000000000104e603 in agui::Widget::autoDestructWhenRemovedFromParent() at /tmp/factorio-FlJt8n/libraries/Agui/include/Agui/Widget.hpp:454
#15 0x0000000000950042 in BlueprintWidget* agui::hold<BlueprintWidget>(BlueprintWidget*) at /tmp/factorio-FlJt8n/libraries/Agui/include/Agui/Widget.hpp:505
#16 0x0000000000c106a7 in BlueprintDescriptionItem::show(Description::StyleSpecification const&, bool) const at /tmp/factorio-FlJt8n/src/Description/BlueprintDescriptionItem.cpp:18
#17 0x0000000000c26afb in Description::fill(agui::Layout&) const at /tmp/factorio-FlJt8n/src/Util/Description.cpp:229
#18 0x0000000000c26f56 in BlueprintRecordSlotTooltip::updateContent() at /tmp/factorio-FlJt8n/src/Gui/BlueprintRecordSlotButton.cpp:31
#19 0x0000000000426d11 in agui::Gui::logic() at ??:?
#20 (nil) in GlobalContext::updateGui() at /tmp/factorio-FlJt8n/src/GlobalContext.cpp:1176
#21 0x000000000042b33f in MainLoop::prepare() at /tmp/factorio-FlJt8n/src/MainLoop.cpp:784
  90.286 Warning Logger.cpp:446: Symbols.size() == 29, usedSize == 21
  90.286 Error CrashHandler.cpp:128: Map tick at moment of crash: 525190
  90.286 Error Util.cpp:67: Unexpected error occurred. If you're running the latest version of the game you can help us solve the problem by posting the contents of the log file on the Factorio forums.
Mods in use:

Code: Select all

5dim_automatization_0.16.0.zip
5dim_battlefield_0.16.0.zip
5dim_botrecaller_0.16.0.zip
5dim_core_0.16.1.zip
5dim_decoration_0.16.0.zip
5dim_energy_0.16.1.zip
5dim_equipment_0.16.0.zip
5dim_infiniteresearch_0.16.0.zip
5dim_locale_0.16.0.zip
5dim_logistic_0.16.0.zip
5dim_mining_0.16.0.zip
5dim_module_0.16.0.zip
5dim_nuclear_0.16.0.zip
5dim_resources_0.16.0.zip
5dim_trade_0.16.0.zip
5dim_trains_0.16.0.zip
5dim_transport_0.16.0.zip
5dim_vehicle_0.16.0.zip
Update: this happens also with the KoS shopping mall - you can download
the blueprint here: https://docs.google.com/document/d/1xZq ... AaVXs/edit

It seems to be related to 5dim's mods. The bug does not happen if I do the same without the mods.
Last edited by Tritano on Sat Dec 16, 2017 11:48 am, edited 2 times in total.

Loewchen
Global Moderator
Global Moderator
Posts: 5468
Joined: Wed Jan 07, 2015 5:53 pm
Contact:

Re: [0.16.3] Crash when clicking a blueprint

Post by Loewchen » Sat Dec 16, 2017 11:25 am

Post the save, the complete log and any mods you might use.

Tritano
Burner Inserter
Burner Inserter
Posts: 17
Joined: Tue Sep 22, 2015 5:12 pm
Contact:

Re: [0.16.3] Crash when hovering a blueprint

Post by Tritano » Sat Dec 16, 2017 11:49 am

I updated my bug report accordingly.
The save is not necessary, it happens also when creating a new game with default settings.

Rseding91
Factorio Staff
Factorio Staff
Posts: 9977
Joined: Wed Jun 11, 2014 5:23 am
Contact:

Re: [0.16.3] Crash when hovering a blueprint

Post by Rseding91 » Sat Dec 16, 2017 3:04 pm

Please upload all of the mods required to reproduce the crash as well.
If you want to get ahold of me I'm almost always on Discord.

Tritano
Burner Inserter
Burner Inserter
Posts: 17
Joined: Tue Sep 22, 2015 5:12 pm
Contact:

Re: [0.16.3] Crash when hovering a blueprint

Post by Tritano » Sat Dec 16, 2017 4:26 pm

I did some testing - it is sufficient to have the attached two mods in order to reproduce the bug:
5dim_automatization_0.16.0.zip
(2.01 MiB) Downloaded 30 times
5dim_core_0.16.1.zip
(108.22 KiB) Downloaded 36 times
To reproduce:

Generate a new world, default settings.
Import this blueprint:
blueprint.txt
(3.82 KiB) Downloaded 51 times
Put the blueprint into the blueprint library somewhere.
Hover with the mouse over the blueprint in the library.

This is the log:
factorio-current.log
(48.27 KiB) Downloaded 52 times

Rseding91
Factorio Staff
Factorio Staff
Posts: 9977
Joined: Wed Jun 11, 2014 5:23 am
Contact:

Re: [0.16.3] Crash when hovering a blueprint

Post by Rseding91 » Sat Dec 16, 2017 4:55 pm

Thanks for the report. It's now fixed for the next version of 0.16.
If you want to get ahold of me I'm almost always on Discord.

Tritano
Burner Inserter
Burner Inserter
Posts: 17
Joined: Tue Sep 22, 2015 5:12 pm
Contact:

Re: [0.16.3] Crash when hovering a blueprint

Post by Tritano » Sat Dec 16, 2017 6:02 pm

Thank you very much!
I did not expect that you guys work today...

Post Reply

Return to “Resolved Problems and Bugs”

Who is online

Users browsing this forum: No registered users