[Oxyd] candidate-chunks does not work correct with old maps

This subforum contains all the issues which we already resolved.
Post Reply
Fense
Manual Inserter
Manual Inserter
Posts: 2
Joined: Sat Dec 16, 2017 2:32 am
Contact:

[Oxyd] candidate-chunks does not work correct with old maps

Post by Fense » Sat Dec 16, 2017 3:33 am

Since updating to 0.16, I have found that the feature of "show-enemy-expansion-candidate-chunks" hasn't been working the same to what it did in 0.15. Instead of showing the full radius of possible expansions, it shows at best a splotch of individual chunks as seen below.

For my new map generated when 0.16.0 was released:
Image

For my pervious map made in later into 0.15:
Image

Before updating on the map I made in 0.15, the map displayed all possible candidate chunks available. The map was pretty much covered in green or red circles, illustrating for every chunk (seen below) and not just a few (like above).

Screenshot of my minimap before the 0.16 update:
Image

I have no clue if anyone else experiences these issues, as no one on the forums or via google searches are talking about this. I know its a bit scummy to always know where enemies spawn from, and it takes the element of surprise out of the fun but I use it so I know which bases are being polluted and should be attacked first if I cannot see them. I doubt that this issue was intentionally changed, as the game would still need to calculate the candidate chunks in any case, where removing some chunks that say 1.000 or include a green circle on top of a chunk would not be as intensive as scanning for all entities and showing it on the same debug overlay.

I have not installed any mods, nor my problem revolves around desync (hence why I have not posted these files in this report). I have had this issue since updating from 0.15.40 to version 0.16.1, and since updating to .2 and .3. The obvious solution of reloading the save or game doesn't achieve anything, and as mentioned before this has occurred through 3 consecutive updates.

Thank you for your considerations, Factorio has easily made my most played game this year! Have a great holiday season and a happy new year :D
Attachments
0.16.zip
My newly created map [16.1]
(5.36 MiB) Downloaded 16 times
Y3 Summer Break.zip
My 2nd latest map made in [15.40]
(9.99 MiB) Downloaded 18 times
factorio-current.log
(34.1 KiB) Downloaded 19 times
priormm.png
Screenshot of minimap from 0.15.40
priormm.png (279.31 KiB) Viewed 1231 times
15map.png
Screenshot of the 0.15.40 map in 0.16.3
15map.png (194.67 KiB) Viewed 1231 times
16map.png
Screenshot of 0.16.1 map in 0.16.3
16map.png (178.72 KiB) Viewed 1231 times

Fense
Manual Inserter
Manual Inserter
Posts: 2
Joined: Sat Dec 16, 2017 2:32 am
Contact:

Re: [16.3] Error in show-enemy-expansion-candidate-chunks

Post by Fense » Sat Dec 16, 2017 5:36 am

Update: Made a new map and the debug option works fine. However loading older save files still presents the issue.

Oxyd
Factorio Staff
Factorio Staff
Posts: 1245
Joined: Thu May 07, 2015 8:42 am
Contact:

Re: [Oxyd] candidate-chunks does not work correct with old maps

Post by Oxyd » Tue Dec 19, 2017 3:39 pm

Thanks. Fixed in 0.16.7.

Post Reply

Return to “Resolved Problems and Bugs”

Who is online

Users browsing this forum: Google [Bot]