[Rseding91] Screen "judders" (skips frames) while driving around base.

This subforum contains all the issues which we already resolved.
Post Reply
Kaiji
Inserter
Inserter
Posts: 22
Joined: Fri Mar 18, 2016 10:46 pm
Contact:

[Rseding91] Screen "judders" (skips frames) while driving around base.

Post by Kaiji » Fri Dec 15, 2017 5:53 pm

I've notice this problem for quite some time now and I've been hoping it would get fixed, but it might just be that it hasn't been noticed. It's subtle but I find it very offputting and immersion breaking while driving my car around my base.

It's happened with every version of the game since it first came out, including the latest beta.

You can test this by holding down W and D to drive in a circle while you're near a group of entities. If you watch one of the entities you'll notice that at one or more specific points of the circle, the screen "jolts" or "lurches". Then as you drive around normally you'll notice these subtle frame skips occur frequently.

I've tested this with two computers with completely different setups so I'm confident it's not an issue on my end.

I really hope this can be fixed because as silly as it might sound it actually puts me off playing because it gives an otherwise amazingly polished game a "janky" feel.
Last edited by Kaiji on Fri Dec 15, 2017 6:45 pm, edited 1 time in total.


User avatar
Jon8RFC
Filter Inserter
Filter Inserter
Posts: 363
Joined: Tue May 10, 2016 3:39 pm
Contact:

Re: Screen "judders" (skips frames) while driving around base.

Post by Jon8RFC » Fri Dec 15, 2017 6:40 pm

Have you tried setting video memory usage to "all"? It was easiest for me to notice the unsmooth operation when running or driving. Standing still I couldn't notice it unless I stared at the UPS/FPS counter.
Image

Kaiji
Inserter
Inserter
Posts: 22
Joined: Fri Mar 18, 2016 10:46 pm
Contact:

Re: Screen "judders" (skips frames) while driving around base.

Post by Kaiji » Fri Dec 15, 2017 6:49 pm

Loewchen wrote:Comply with these please:
viewtopic.php?f=7&t=3638
viewtopic.php?f=7&t=51319
Thanks.

I updated my OP to state that this has always been an issue with every release, and it's not a performance problem - the game runs buttery smooth apart from these frame skips when driving. It's a bug with the game.

Sometimes it seems like it happens when you drive over a spot where a sound is played so I'm not sure if that has something to do with it.
Jon8RFC wrote:Have you tried setting video memory usage to "all"? It was easiest for me to notice the unsmooth operation when running or driving. Standing still I couldn't notice it unless I stared at the UPS/FPS counter.

I notice it whatever my configuration is, but only when driving. I guess it must also happen when walking but I don't notice it because it's much slower movement.

User avatar
Jon8RFC
Filter Inserter
Filter Inserter
Posts: 363
Joined: Tue May 10, 2016 3:39 pm
Contact:

Re: Screen "judders" (skips frames) while driving around base.

Post by Jon8RFC » Fri Dec 15, 2017 6:54 pm

Just to clarify if you'd like to try it, it's "always" happened to me since I began using the high res graphics. On some days, it reliably acts up when running/driving North; on other days, it's another direction. It reliably smooths out when set to "all". I'd be curious to know if that helps out your situation as well.

EDIT: Ah, you updated your post. If you've tried "all" and restarted your game, then I guess that's not the fix for you as well. Bummer.
Image

Kaiji
Inserter
Inserter
Posts: 22
Joined: Fri Mar 18, 2016 10:46 pm
Contact:

Re: Screen "judders" (skips frames) while driving around base.

Post by Kaiji » Fri Dec 15, 2017 11:36 pm

Jon8RFC wrote:I guess that's not the fix for you as well. Bummer.
I've seen exactly the same issue on a number of different PC builds over the years. The "lurching" happens at precise locations rather than randomly, which strongly suggests that it's an optimization issue rather than a hardware issue. The game seems to be hitching because it's processing the same thing every time you pass over a certain point.

Using the method I described in the OP (hold down W and D and drive in a circle near some entities), anyone can see this engine behaviour.

I know the devs are obsessive about optimizing their game so I hope to see this irritating issue fixed before too long. It really does give an otherwise excellent game a shoddy, cheap feel.

Rseding91
Factorio Staff
Factorio Staff
Posts: 9464
Joined: Wed Jun 11, 2014 5:23 am
Contact:

Re: Screen "judders" (skips frames) while driving around base.

Post by Rseding91 » Sat Dec 16, 2017 7:11 am

Kaiji wrote:
Jon8RFC wrote:I guess that's not the fix for you as well. Bummer.
I've seen exactly the same issue on a number of different PC builds over the years. The "lurching" happens at precise locations rather than randomly, which strongly suggests that it's an optimization issue rather than a hardware issue. The game seems to be hitching because it's processing the same thing every time you pass over a certain point.

Using the method I described in the OP (hold down W and D and drive in a circle near some entities), anyone can see this engine behaviour.

I know the devs are obsessive about optimizing their game so I hope to see this irritating issue fixed before too long. It really does give an otherwise excellent game a shoddy, cheap feel.
Can you give an example?
If you want to get ahold of me I'm almost always on Discord.

Kaiji
Inserter
Inserter
Posts: 22
Joined: Fri Mar 18, 2016 10:46 pm
Contact:

Re: Screen "judders" (skips frames) while driving around base.

Post by Kaiji » Sat Dec 16, 2017 12:48 pm

Rseding91 wrote:
Kaiji wrote:
Jon8RFC wrote:I guess that's not the fix for you as well. Bummer.
I've seen exactly the same issue on a number of different PC builds over the years. The "lurching" happens at precise locations rather than randomly, which strongly suggests that it's an optimization issue rather than a hardware issue. The game seems to be hitching because it's processing the same thing every time you pass over a certain point.

Using the method I described in the OP (hold down W and D and drive in a circle near some entities), anyone can see this engine behaviour.

I know the devs are obsessive about optimizing their game so I hope to see this irritating issue fixed before too long. It really does give an otherwise excellent game a shoddy, cheap feel.
Can you give an example?
Thanks for your attention.

I've uploaded a video here:

http://www95.zippyshare.com/v/DOoS3KuZ/file.html

I drive around in three random circles. The frame lurching can be noticed in the first circle at 2 o'clock, the second circle skips at 3 o'clock, and the third skips twice - once at 5 o'clock and again at 8 o'clock.

It seems to coincide with a sound being played.

Rseding91
Factorio Staff
Factorio Staff
Posts: 9464
Joined: Wed Jun 11, 2014 5:23 am
Contact:

Re: Screen "judders" (skips frames) while driving around base.

Post by Rseding91 » Sat Dec 16, 2017 2:07 pm

Can you press Shift + space and upload a screenshot of that area of your factory?
If you want to get ahold of me I'm almost always on Discord.


JohnKnife
Burner Inserter
Burner Inserter
Posts: 6
Joined: Sat Dec 16, 2017 6:24 pm
Contact:

Re: Screen "judders" (skips frames) while driving around base.

Post by JohnKnife » Tue Dec 19, 2017 10:14 am

I might have had the exact same problem as you: viewtopic.php?f=7&t=55059

Check you VRAM usage. It is probably maxed out causing excessive swapping to main memory.

My 3GB card does not have enough storage for high res sprites and VRAM usage "All". You need 4GB at least for this sprite game lol.

Simple fix: reduce VRAM usage to "High".

Kaiji
Inserter
Inserter
Posts: 22
Joined: Fri Mar 18, 2016 10:46 pm
Contact:

Re: Screen "judders" (skips frames) while driving around base.

Post by Kaiji » Tue Dec 19, 2017 3:53 pm

I have a 6 gig GTX 1060 and a Ryzen 7.

As I said, this happens regardless of my settings, and I've seen it on several different builds over the years.

Hoping to see it fixed before too long.

cbhj1
Fast Inserter
Fast Inserter
Posts: 106
Joined: Tue Apr 25, 2017 2:53 pm
Contact:

Re: Screen "judders" (skips frames) while driving around base.

Post by cbhj1 » Tue Dec 19, 2017 4:29 pm

if you display the debug time used, is there a big fluctuation in the flip time? all these reports of unstable frame rate seem to be nvidia cards from what I've seen

Rseding91
Factorio Staff
Factorio Staff
Posts: 9464
Joined: Wed Jun 11, 2014 5:23 am
Contact:

Re: [Rseding91] Screen "judders" (skips frames) while driving around base.

Post by Rseding91 » Tue Dec 19, 2017 5:11 pm

Ok, I've fixed it for the next version of 0.16.
If you want to get ahold of me I'm almost always on Discord.

Kaiji
Inserter
Inserter
Posts: 22
Joined: Fri Mar 18, 2016 10:46 pm
Contact:

Re: [Rseding91] Screen "judders" (skips frames) while driving around base.

Post by Kaiji » Tue Dec 19, 2017 6:44 pm

Rseding91 wrote:Ok, I've fixed it for the next version of 0.16.
:o

Thanks a million!! :D :D :D :D

Kaiji
Inserter
Inserter
Posts: 22
Joined: Fri Mar 18, 2016 10:46 pm
Contact:

Re: [Rseding91] Screen "judders" (skips frames) while driving around base.

Post by Kaiji » Thu Dec 21, 2017 7:23 pm

Just tested the new patch. Driving is SOOOOOOOOOOOOOOOO SMOOOOOOOTH!!!!!!!!!!!

You guys are the best devs in the history of gaming.

Post Reply

Return to “Resolved Problems and Bugs”

Who is online

Users browsing this forum: No registered users