[Rseding91] [0.16.3] can't configure combinators with use-item-groups disabled

This subforum contains all the issues which we already resolved.
Post Reply
quyxkh
Filter Inserter
Filter Inserter
Posts: 712
Joined: Sun May 08, 2016 9:01 am
Contact:

[Rseding91] [0.16.3] can't configure combinators with use-item-groups disabled

Post by quyxkh » Fri Dec 15, 2017 3:40 pm

54728 says it's fixed, but 16.3 behaves identically and has no mention of it in the changelog...

daniel34
Global Moderator
Global Moderator
Posts: 2757
Joined: Thu Dec 25, 2014 7:30 am
Contact:

Re: [16.3]54728 fix not in 16.3

Post by daniel34 » Fri Dec 15, 2017 3:47 pm

quyxkh wrote:54728 says it's fixed, but 16.3 behaves identically and has no mention of it in the changelog...
Are you sure? It's working for me. It also works when subgroups are disabled.

Image

quyxkh
Filter Inserter
Filter Inserter
Posts: 712
Joined: Sun May 08, 2016 9:01 am
Contact:

Re: [16.3]54728 fix not in 16.3

Post by quyxkh » Fri Dec 15, 2017 4:03 pm

Hunh. I get your behavior with plain vanilla, the reported behavior with my mods running. I'll put together a minimal-case reproducer.

edit: setting the use-item-groups = false preference in the config reproduces the behavior even in vanilla, I'll keep looking for what's going on with the mods but that might be enough to make a connection.


with use-item-groups=false in config.ini, regardless of mods, the api calls have no effect and the signal-picker window is blank.

with use-item-groups unspecified in config.ini, in vanilla everything works right, but with my mods everything behaves as reported in 54728

with use-item-groups=true in config.ini, regardless of mods, everything works right, including the api calls [whine](except that the option still has no ui)[/whine]

So I've got a workaround. I'll edit in more details on what it takes to reproduce the unspecified-value case with mods as and when.

daniel34
Global Moderator
Global Moderator
Posts: 2757
Joined: Thu Dec 25, 2014 7:30 am
Contact:

Re: [16.3]54728 fix not in 16.3

Post by daniel34 » Fri Dec 15, 2017 4:39 pm

I can confirm, in 0.16.3 if you set use-item-groups to false in the config file it will trigger the bug and display an empty 'Select a signal' window.

Actually, what is the purpose of LuaPlayer.enable_recipe_groups? It doesn't have any effect right now. I assume it should enable them if they were disabled via the config file, however that's not working.

On another note, "Use item groups" and "Use item subgroups" have been removed from Options --> Other. I assume this has been done on purpose and the only ways to set it now are the config file or using the console/mods?

Rseding91
Factorio Staff
Factorio Staff
Posts: 9436
Joined: Wed Jun 11, 2014 5:23 am
Contact:

Re: [0.16.3] can't configure combinators with use-item-groups disabled

Post by Rseding91 » Sat Dec 16, 2017 6:13 am

Thanks for the report. I've fixed it so the config option works properly now in 0.16.4.
If you want to get ahold of me I'm almost always on Discord.

Post Reply

Return to “Resolved Problems and Bugs”

Who is online

Users browsing this forum: No registered users