[posila][16.2] Corrupted Game State

Place for things which are bugs but we have no idea how to solve them. Things related to hardware, libraries, strange setups, etc.
Post Reply
AntoninLipsky
Manual Inserter
Manual Inserter
Posts: 1
Joined: Thu Dec 14, 2017 9:05 pm
Contact:

[posila][16.2] Corrupted Game State

Post by AntoninLipsky »

I'm reporting a game state corruption as requested by the game.

What I happened:
I walked south, build a few turrets and put ammunition in them. Then a dialog popped up telling me the game state was corrupted and to please post the saves in this forum.
So I saved the game and quit. In order to remember what I did before the dialog, I then started the game again and loaded the save. The game crashed.

Other info:
I've never experienced a Factorio crash before.
I run a fairly up-to-date Arch Linux on an older Thinkpad Edge. (I'll refrain from updating for a few days in case you're interested in any installed libs etc)
I did not use any mods at the time, but I used some before updating to 0.16.
I started the game when 0.15 came out and used the mods Long Reach, Bottleneck, Clean Concrete and Squeeze Through

You'll find the following attachments:
before_broken.zip: the latest autosave before the game state was corrupted
broken.zip: the save immediately after being shown the dialog
session_with_dialog.log: the application log of the session which ended with the dialog
trying_to_load_corrupted_save.log: the application log of the session in which I tried to load the corrupted save (what is now 'broken.zip')
Attachments
trying_to_load_corrupted_save.log
Log of session where I tried to reload corrupted save
(5.77 KiB) Downloaded 126 times
session_with_dialog.log
Log of session where dialog came up
(7.42 KiB) Downloaded 123 times
broken.zip
Save after corruption dialog
(15.62 MiB) Downloaded 101 times
before_broken.zip
Most recent uncorrupted save
(15.83 MiB) Downloaded 99 times

posila
Factorio Staff
Factorio Staff
Posts: 5040
Joined: Thu Jun 11, 2015 1:35 pm
Contact:

Re: [posila][16.2] Corrupted Game State

Post by posila »

Thanks for the report.
Unfortunatelly, it looks like it was caused by random memory corruption.

Post Reply

Return to “1 / 0 magic”