[Rseding91] [0.16.2] Force-placing blueprints duplicates alpha for rails

This subforum contains all the issues which we already resolved.
Post Reply
User avatar
Sparen
Inserter
Inserter
Posts: 33
Joined: Thu Jun 30, 2016 1:25 am
Contact:

[Rseding91] [0.16.2] Force-placing blueprints duplicates alpha for rails

Post by Sparen »

When force-placing (for my key-mapping, shift-left click; whatever binding is used to place components of a blueprint even when not all objects can be placed (build ghost option?)) blueprints that overlap with one another, the parts that are shared between the blueprints render with a higher alpha due to the combined alpha of the components.

Taken to the extreme by force placing a blueprint on top of itself a couple dozen times, you get the following (see attachment)
Screen Shot 2017-12-14 at 1.27.03 PM.png
Screen Shot 2017-12-14 at 1.27.03 PM.png (406.89 KiB) Viewed 1347 times
It was generated by placing the left component once, and overlaying the right component around 30 times.

For more general use, see the following:
Screen Shot 2017-12-14 at 1.36.37 PM.png
Screen Shot 2017-12-14 at 1.36.37 PM.png (989.57 KiB) Viewed 1347 times
In this image, the top set is placed overlapping without any issues, while in the bottom set, the right blueprint was force-placed. As you can see, the overlapping unit of rail is brighter.

This bug isn't game-breaking or anything but I do not believe it to be intentional. I believe that it only affects rails.

User avatar
Sparen
Inserter
Inserter
Posts: 33
Joined: Thu Jun 30, 2016 1:25 am
Contact:

Re: [0.16.2] Force-placing blueprints duplicates alpha for rails

Post by Sparen »

Additional note:
Screen Shot 2017-12-14 at 1.53.51 PM.png
Screen Shot 2017-12-14 at 1.53.51 PM.png (1.13 MiB) Viewed 1337 times
It seems like this also affect Blueprint Preview, as the blueprint requires significantly more rail than it actually needs and the rail alpha in the preview is affected.

Rseding91
Factorio Staff
Factorio Staff
Posts: 11923
Joined: Wed Jun 11, 2014 5:23 am
Contact:

Re: [Rseding91] [0.16.2] Force-placing blueprints duplicates alpha for rails

Post by Rseding91 »

Thanks for the report. It's now fixed for the next version of 0.16.
If you want to get ahold of me I'm almost always on Discord.

Post Reply

Return to “Resolved Problems and Bugs”