[Rseding91] [16.0] "Invalid index 145 for Direction" w/ modded save

This subforum contains all the issues which we already resolved.
Post Reply
dewiniaid
Long Handed Inserter
Long Handed Inserter
Posts: 92
Joined: Tue Mar 07, 2017 8:50 pm
Contact:

[Rseding91] [16.0] "Invalid index 145 for Direction" w/ modded save

Post by dewiniaid » Wed Dec 13, 2017 7:31 pm

The following saves include my mod Batteries Not Included.

The 0.15 version of the save loads correctly (in Factorio 0.16) with Batteries Not Included disabled, with the usual reports of missing entities, etc. being removed from the save.

The 0.16 version of the save fails to load with the error "Invalid index 145 for Direction" with the mod disabled. With the mod enabled, it works fine.
Attachments
factorio-current.log
Log file after failed load attempt
(4.25 KiB) Downloaded 20 times
Save from 0.16.zip
Version last saved in Factorio 0.16.0
(4.15 MiB) Downloaded 16 times
Save from 0.15.zip
Version last saved in Factorio 0.15.37
(4.24 MiB) Downloaded 15 times
Last edited by dewiniaid on Wed Dec 13, 2017 8:12 pm, edited 1 time in total.

Loewchen
Global Moderator
Global Moderator
Posts: 5202
Joined: Wed Jan 07, 2015 5:53 pm
Contact:

Re: [16.0] "Invalid index 145 for Direction" w/ modded save

Post by Loewchen » Wed Dec 13, 2017 7:54 pm

Post the log with the issue please.

dewiniaid
Long Handed Inserter
Long Handed Inserter
Posts: 92
Joined: Tue Mar 07, 2017 8:50 pm
Contact:

Re: [16.0] "Invalid index 145 for Direction" w/ modded save

Post by dewiniaid » Wed Dec 13, 2017 8:13 pm

Loewchen wrote:Post the log with the issue please.
Added to OP.

Rseding91
Factorio Staff
Factorio Staff
Posts: 9453
Joined: Wed Jun 11, 2014 5:23 am
Contact:

Re: [Rseding91] [16.0] "Invalid index 145 for Direction" w/ modded save

Post by Rseding91 » Wed Dec 13, 2017 8:30 pm

Thanks for the report. I've found the problem and it's fixed for 0.16.2. 0.16.1 is already in-process of being released.
If you want to get ahold of me I'm almost always on Discord.

Post Reply

Return to “Resolved Problems and Bugs”

Who is online

Users browsing this forum: No registered users