[Rseding91] [0.16.0]Modded Savegame: Error when loading savegame: Unknown GUI type 0

This subforum contains all the issues which we already resolved.
Post Reply
User avatar
Bart
Long Handed Inserter
Long Handed Inserter
Posts: 81
Joined: Tue Jan 13, 2015 8:56 pm
Contact:

[Rseding91] [0.16.0]Modded Savegame: Error when loading savegame: Unknown GUI type 0

Post by Bart » Wed Dec 13, 2017 2:10 pm

When loading a game from 0.15.40 with FARL as only mod installed, in 0.16.0 I get an error when loading:

Image

Unknown GUI type: 0

Savegame: http://lingen.nu/b13.zip
I have the cape.
I make the fucking whoosh noises.

Loewchen
Global Moderator
Global Moderator
Posts: 5202
Joined: Wed Jan 07, 2015 5:53 pm
Contact:

Re: [0.16.0] Error when loading savegame: Unknown GUI type 0

Post by Loewchen » Wed Dec 13, 2017 2:13 pm

Are you using mods?
Where you using mods on the save previously, but are not now when loading it?
For completeness, post the log after a session with the issue please.

User avatar
Bart
Long Handed Inserter
Long Handed Inserter
Posts: 81
Joined: Tue Jan 13, 2015 8:56 pm
Contact:

Re: [0.16.0]Modded Savegame: Error when loading savegame: Unknown GUI type 0

Post by Bart » Wed Dec 13, 2017 2:30 pm

I was only using FARL 1.1.8 with Factorio 0.15.40.

I am only using FARL 2.0.1 with Factorio 0.16.0

I also tried loading the game in 0.16.0 without FARL (or any other mod), same error.

Here's the log:

Code: Select all

  0.001 2017-12-13 15:29:28; Factorio 0.16.0 (build 34159, win64, steam)
   0.001 Operating system: Windows 10 (version 1703) 
   0.001 Program arguments: "C:\Games\Steam\steamapps\common\Factorio\bin\x64\Factorio.exe" 
   0.001 Read data path: C:/Games/Steam/steamapps/common/Factorio/data
   0.001 Write data path: C:/Users/Bart/AppData/Roaming/Factorio [85305/475986MB]
   0.001 Binaries path: C:/Games/Steam/steamapps/common/Factorio/bin
   0.010 System info: [CPU: Intel(R) Core(TM) i5-4670K CPU @ 3.40GHz, 4 cores, RAM: 16262MB]
   0.011 Display options: [FullScreen: 1] [VSync: 1] [UIScale: system (100.0%)] [MultiSampling: OFF] [Screen: 0] [Lang: en]
   0.012 Available display adapters: 2
   0.012  [0]: \\.\DISPLAY1 - NVIDIA GeForce GTX 1080 Ti {0x05, [0,0], 2560x1440, 32bit, 144Hz}
   0.013  [1]: \\.\DISPLAY2 - NVIDIA GeForce GTX 1080 Ti {0x01, [-1920,345], 1920x1080, 32bit, 60Hz}
   0.013 Create display on adapter 0. Size 1280x720 at position [630, 342].
   0.173 Initialised Direct3D:[0] NVIDIA GeForce GTX 1080 Ti; driver: nvldumdx.dll 23.21.13.8813
   0.179   Video memory size (dedicated video/dedicated system/shared system/available): 11132/0/8131/4082 MB
   0.253 DSound: Starting _dsound_update thread
   0.253 DSound: Enter _dsound_update; tid=11388
   0.254 Device reset internal.
   0.255 Desktop composition is active.
   0.255 WARNING: You have vsync and desktop composition enabled on Direct3D. Consider disabling vsync to increase performance on some configurations.
   0.255 Graphics settings preset: very-high
   0.255 Graphics options: [Graphics quality: high] [Video memory usage: all] [Light scale: 100%] [DXT: false] [Shader: 1]
   0.255                   [Parallel sprite loading: 1] [Max texture size: 0/8192] [Bmp cache: 0] [Sprite slicing: 1] [Low quality rotation: 0]
   0.359 Loading mod core 0.0.0 (data.lua)
   0.393 Loading mod base 0.16.0 (data.lua)
   0.504 Loading mod FARL 2.0.1 (data.lua)
   0.543 Loading mod base 0.16.0 (data-updates.lua)
   0.584 Loading mod FARL 2.0.1 (data-updates.lua)
   0.620 Loading mod FARL 2.0.1 (data-final-fixes.lua)
   0.660 Checksum for core: 3886358456
   0.660 Checksum of base: 2132534782
   0.660 Checksum of FARL: 1212406221
   0.762 Loading sounds...
   0.828 Info PlayerData.cpp:67: Local player-data.json unavailable
   0.828 Info PlayerData.cpp:70: Cloud player-data.json available, timestamp 1513170170
   0.927 Loaded shader file C:/Games/Steam/steamapps/common/Factorio/data/core/graphics/shaders/game.cso
   0.927 Loaded shader file C:/Games/Steam/steamapps/common/Factorio/data/core/graphics/shaders/zoom-to-world.cso
   0.928 Loaded shader file C:/Games/Steam/steamapps/common/Factorio/data/core/graphics/shaders/alpha-mask.cso
   0.944 Initial atlas bitmap size is 16384
   0.974 Created atlas bitmap 16384x16381 [none]
   1.321 Created atlas bitmap 16384x4246 [none]
   1.406 Created atlas bitmap 16384x9565 [shadow]
   1.591 Created atlas bitmap 16384x2104 [decal]
   1.636 Created atlas bitmap 8192x5568 [mipmap]
   1.688 Created atlas bitmap 8192x800 [mipmap, smoke]
   1.696 Created atlas bitmap 8192x8168 [linear-minification, mipmap, terrain]
   1.772 Created atlas bitmap 8192x2100 [no-crop, trilinear-filtering, icon, light]
   1.790 Created atlas bitmap 8192x924 [alpha-mask]
  10.386 Sprites loaded
  10.386 Convert atlas 8192x5568 to: mipmap 
  10.524 Convert atlas 8192x800 to: mipmap 
  10.585 Convert atlas 8192x8168 to: min-linear 
  10.777 Convert atlas 8192x2100 to: trilinear-filtering 
  10.918 Convert atlas 8192x924 to: alpha-mask
  11.568 Custom inputs active: 1
  11.603 Factorio initialised
  11.616 Error FileUtil.cpp:358: Couldn't remove C:\Users\Bart\AppData\Roaming\Factorio\temp: operation not permitted
  14.921 Loading map C:\Users\Bart\AppData\Roaming\Factorio\saves\b13.zip: 34790372 bytes.
  15.043 Loading Level.dat: 73262707 bytes.
  15.050 Info Scenario.cpp:135: Map version 0.15.40-0
  15.055 Info PrototypeMigrationList.cpp:51: Activating migration base/2017-12-03_Factorio_0.16.0.json
  16.862 Warning Map.cpp:294: Map loading failed: Unknown gui type: 0
  17.232 Error AppManagerStates.cpp:1195: Unknown gui type: 0
  21.568 DSound: Stopping voice
  21.568 DSound: Joining thread
  21.571 DSound: Exit _dsound_update; tid=11388
  21.571 DSound: Waiting for voice to stop ... signaled
  21.571 DSound: Joined thread
  21.571 DSound: Destroying thread
  21.571 DSound: Thread destroyed
  21.571 DSound: Releasing buffer
  21.571 DSound: Voice stopped
  21.571 DSound: Deallocating voice
  21.571 DSound: Deallocated voice
  21.628 Steam API shutdown.
  21.630 Goodbye
I have the cape.
I make the fucking whoosh noises.

Rseding91
Factorio Staff
Factorio Staff
Posts: 9453
Joined: Wed Jun 11, 2014 5:23 am
Contact:

Re: [Rseding91] [0.16.0]Modded Savegame: Error when loading savegame: Unknown GUI type 0

Post by Rseding91 » Wed Dec 13, 2017 3:45 pm

Thanks for the report. I've fixed the problem for 0.16.1 but if you load it in 0.15.40 without the mod and re-save it you can load it in 0.16.0 in the meantime.

There's an error in the loading of progress bar styles that it wouldn't load everything it was supposed to and results in this error.
If you want to get ahold of me I'm almost always on Discord.

User avatar
Bart
Long Handed Inserter
Long Handed Inserter
Posts: 81
Joined: Tue Jan 13, 2015 8:56 pm
Contact:

Re: [Rseding91] [0.16.0]Modded Savegame: Error when loading savegame: Unknown GUI type 0

Post by Bart » Wed Dec 13, 2017 6:31 pm

Thanks :)
I'll just wait for 0.16.1!
I have the cape.
I make the fucking whoosh noises.

Post Reply

Return to “Resolved Problems and Bugs”

Who is online

Users browsing this forum: Bing [Bot]