[Dominik] [15.34] Train station skipped if one activated and one deactivated same tick

This subforum contains all the issues which we already resolved.
Post Reply
gheift
Fast Inserter
Fast Inserter
Posts: 184
Joined: Tue Mar 03, 2015 9:20 pm
Contact:

[Dominik] [15.34] Train station skipped if one activated and one deactivated same tick

Post by gheift » Tue Sep 12, 2017 11:30 am

Hi,

if I have following situation:
  • three stations 1*A, 2*B
  • a train which just drives from A to B, back and forth
  • the two B stations are connected to the same circuit network
  • the condition is mutual exclusive, e.g "red = 0" and "red ≠ 0"
  • if the signal red changes from 0 to 1, one station is disabled and the second one is enabled in the same tick
  • the train does not as expected route itself to the other B station but instead goes back to A
I played a little bit and created a minimal test case. Looks like it depends somehow on the build order or how the stations are renamed.

The top line works as expected.
The second line has the behavior described above.
The third line skips the second station which should be available on rerouting.
The fourth line works as expected again.

Kind regards,
Gerhard
Attachments
Bug-Trainstation.zip
(2.66 MiB) Downloaded 49 times

Dominik
Factorio Staff
Factorio Staff
Posts: 657
Joined: Sat Oct 12, 2013 9:08 am
Contact:

Re: [Dominik] [15.34] Train station skipped if one activated and one deactivated same tick

Post by Dominik » Tue Oct 03, 2017 10:57 am

Hi, thank you for pointing this out, this behavior is incorrect. And thanks for the great save file reproducing it :) We have fixed it by processing the train repathings only by the final state after all station states are updated.

Paul17041993
Inserter
Inserter
Posts: 35
Joined: Fri Nov 25, 2016 4:26 am
Contact:

Re: [Dominik] [15.34] Train station skipped if one activated and one deactivated same tick

Post by Paul17041993 » Sun Oct 15, 2017 4:28 am

Does this also fix the condition with a single station being enabled and the train being sent a 'go' signal, but the train skipping it anyway (and hanging as a result as it has no path)? or should I make a separate report?
Please be sure you've googled your question before asking me about code... :T

Dominik
Factorio Staff
Factorio Staff
Posts: 657
Joined: Sat Oct 12, 2013 9:08 am
Contact:

Re: [Dominik] [15.34] Train station skipped if one activated and one deactivated same tick

Post by Dominik » Mon Oct 16, 2017 11:36 am

I suppose it should, but if you send me a save, I can test it to make sure.

Post Reply

Return to “Resolved Problems and Bugs”

Who is online

Users browsing this forum: No registered users