[kovarex] [15.33] Automatic rail placement does not place directly under cursor

This subforum contains all the issues which we already resolved.
Post Reply
London_
Inserter
Inserter
Posts: 21
Joined: Sat Jul 01, 2017 12:53 am
Contact:

[kovarex] [15.33] Automatic rail placement does not place directly under cursor

Post by London_ » Mon Sep 04, 2017 8:38 pm

When placing track when left clicking the green arrow on tracks the pieces are 1 piece behind the cursor at all times. https://gyazo.com/15b59081dcc10e55c4042283b20b7dc5

However when you Shift+left click to have the game try and meet your mouse, it stays right on top of your mouse. https://gyazo.com/6cedb30f0bc064c0cf2d0ffc645734b9

Is there a reason why the shorter segments don't keep up with the cursor? It's always been annoying when placing rails and being one rail short even though I clicked on the exact distance I wanted the rail to be.

Another thing that has bugged me forever is that when I place down ghost rails, I can't actually place down a rail in the spot you hover over. I have to use the arrows from another ghost or come in from a spot where there's no ghost rails. https://gyazo.com/faff509f35be229b79064d2d465f0889
Attachments
factorio-current.log
(172.08 KiB) Downloaded 37 times

MrMeep
Manual Inserter
Manual Inserter
Posts: 4
Joined: Wed Jul 26, 2017 9:31 am
Contact:

Re: [15.33] Automatic rail placement does not place directly under cursor

Post by MrMeep » Tue Sep 05, 2017 6:01 am

I Think this is intended.
MEEP MEEP MEEP

kovarex
Factorio Staff
Factorio Staff
Posts: 7387
Joined: Wed Feb 06, 2013 12:00 am
Contact:

Re: [kovarex] [15.33] Automatic rail placement does not place directly under cursor

Post by kovarex » Tue Sep 05, 2017 1:32 pm

Thank you for the notice. It kind of annoyed me as well unconsciously. I didn't realize the inconsistency.
The reason for this is, that the algorithm the final path is chosen for manual building is different.
I fixed it so it behaves the same way for manual building as for ghost building for 0.16

BenSeidel
Filter Inserter
Filter Inserter
Posts: 543
Joined: Tue Jun 28, 2016 1:44 am
Contact:

Re: [kovarex] [15.33] Automatic rail placement does not place directly under cursor

Post by BenSeidel » Fri Sep 08, 2017 8:11 am

kovarex wrote: It kind of annoyed me as well unconsciously
Ditto...
Thanks for the fix!! (and for 0.16).

Post Reply

Return to “Resolved Problems and Bugs”

Who is online

Users browsing this forum: No registered users