5 times as many bugs attack in 0.15.15 compared to 0.15.14

This subforum contains all the issues which we already resolved.
Post Reply
mtilsted
Long Handed Inserter
Long Handed Inserter
Posts: 53
Joined: Fri Nov 11, 2016 4:19 pm
Contact:

5 times as many bugs attack in 0.15.15 compared to 0.15.14

Post by mtilsted »

I have attached a game which is a "Death world" 9 hours in. If I run the game for 5 minutes with 0.15.14 anything is fine. There are 2 different attacks, but my laser turret defense can handle that no problem.

If I run it with 0.15.15, after 5 minutes My base is so overrun with biters that all power goes to the laser turrets, and the factory will newer build anything again, because the turrets take all the power, until most of my base have been killed by bitters.

This may be related to the fact that 0.15.15 fixed the fact that some spawners would not work but in that case the bug is that the game need some re-balancing or maybe the issue is only this bad because it happens 9 hours into a game.

Personally I would like a game with fewer bases(Because having to clear 30 spawners just to get access to oil is not fun), but more wave attacks.
Attachments
win8.zip
(7.14 MiB) Downloaded 69 times

Oxyd
Factorio Staff
Factorio Staff
Posts: 1391
Joined: Thu May 07, 2015 8:42 am
Contact:

Re: 5 times as many bugs attack in 0.15.15 compared to 0.15.14

Post by Oxyd »

What happens here is that your spawners have been absorbing pollution for 9 hours, but they haven't been sending units to attack. So now with the bug fixed, they're all sending units like crazy because they have a huge backlog of pollution to go through.

So it's not really a bug per se – it's just a temporary effect until the spawners run out of absorbed pollution. Nevertheless, I made a change to 0.15.16 that will simply reset all spawners on load. This makes your save much more sedate – although you'll probably see more attacks than you did before. They haven't broken through your defences in my testing after I've made that change, though. :)

So let's call this fixed.

Post Reply

Return to “Resolved Problems and Bugs”