[kovarex] [0.15.13] Slow server = no input on client

This subforum contains all the issues which we already resolved.
Post Reply
zamp
Burner Inserter
Burner Inserter
Posts: 6
Joined: Mon Feb 29, 2016 4:13 am
Contact:

[kovarex] [0.15.13] Slow server = no input on client

Post by zamp » Tue May 23, 2017 10:01 pm

If a server is running factorio much slower (30-40 ups) clients running at 60 ups no longer handle input and get stuck. Only workaround I found was forcing client to run at 30FPS and it started to handle input again. Multiplayer wait icon flashes non-stop.
Last edited by zamp on Wed May 24, 2017 2:45 pm, edited 1 time in total.

mindmix
Inserter
Inserter
Posts: 20
Joined: Wed Nov 04, 2015 9:06 pm
Contact:

Re: [0.15.13] Slow server = no input on client

Post by mindmix » Wed May 24, 2017 6:02 am

Multiplayer UPS shows as 0.0
Image

Interaction via the GUI works fine, like ordering trains around, bots and belts work fine, however mousing over items takes anywhere up to a minute to show the yellow highlight box and the information panel.
Movement is almost impossible since it only gets processed randomly, so you can get stuck running in the same direction until the next time the server feels like accepting an input.

triffid_hunter
Inserter
Inserter
Posts: 25
Joined: Wed Dec 14, 2016 7:33 am
Contact:

Re: [0.15.13] Slow server = no input on client

Post by triffid_hunter » Tue Jul 04, 2017 12:29 pm

I've run into this heaps of times, very infuriating especially in the middle of combat!

kovarex
Factorio Staff
Factorio Staff
Posts: 7387
Joined: Wed Feb 06, 2013 12:00 am
Contact:

Re: [kovarex] [0.15.13] Slow server = no input on client

Post by kovarex » Thu Mar 22, 2018 2:30 pm

Thanks for the report. I was postponing fixing this bug for a long time (since the 0.15.13), but it wasn't that big of a beast after all.
Fixed for the next release.

cl0wnt0wn
Burner Inserter
Burner Inserter
Posts: 7
Joined: Thu Apr 28, 2016 8:01 pm
Contact:

Re: [kovarex] [0.15.13] Slow server = no input on client

Post by cl0wnt0wn » Thu Mar 22, 2018 3:14 pm

We will test this on the April 14th PVP event - think this got us on March 10th. :) Thanks much!

=-CT

Post Reply

Return to “Resolved Problems and Bugs”

Who is online

Users browsing this forum: No registered users