[HanziQ] [0.14.6] Trains budge when: rail network changes, & every 3s

This subforum contains all the issues which we already resolved.
Post Reply
uber5001
Burner Inserter
Burner Inserter
Posts: 15
Joined: Thu Sep 15, 2016 8:30 pm
Contact:

[HanziQ] [0.14.6] Trains budge when: rail network changes, & every 3s

Post by uber5001 »

In my current save, when placing or removing any rail segment or signal causes:
  • - A split second of lag (at least when placing rails, this is true, not sure about signals)
    - A certain set of trains will ignore the chain signal they are waiting at for a moment, maybe 1 frame. The train's front headlight may flash, and the train will move forward a small, sometimes imperceptible amount, and immediately stop. I'm just calling this a "budge".
Trains budging eventually causes them pass signals that they would otherwise stay stopped at.

The same set of trains also budge every 3s or so.

I do not know why only a certain set of trains will budge (as opposed to ALL trains waiting at signals).

Trains idly budging

Trains budging on signal placement

Trains passing chain signals

My save file

TheUnknown007
Fast Inserter
Fast Inserter
Posts: 126
Joined: Sun May 03, 2015 9:17 pm
Contact:

[0.14.7] train starts and stops at signal

Post by TheUnknown007 »

I found the following bug:
Note the smoke beneath and over the left train, indicating it starts
Note the smoke beneath and over the left train, indicating it starts
ezgif.com-video-to-gif.gif (16.36 MiB) Viewed 3366 times
Description of situation:
I the left train is in manual mode, I stopped it there to pick up some stone. The right train came after I stopped, and stopped at the signal (it is trying to get to the station to the left). Now, it constantly starts, but since the next block is occupied, it stops directly. I originally parked my train kind of right of the signal, which means that the wagon was right of the signal, but not so much that the other train couldn't stop behind it. I thought moving my train to the left of the signal would help, but it didn't.
The bug is that it shouldn't start in the first place, but just wait until I remove my train.

Note on the saves:
1 was made in the original instance. I moved the train a bit to the left because I thought it would help, but it didn't
2 was made to try to reproduce the issue.
3 is before it happens. Simply switch to manual and stop to reproduce. Note that it also happens with the double signals left of the original one.
Attachments
_autosave2.zip
3
(13.16 MiB) Downloaded 47 times
_bug_train_starts_and_stops_at_signal_2.zip
1
(13.29 MiB) Downloaded 51 times
_bug_train_starts_and_stops_at_signal.zip
2
(13.44 MiB) Downloaded 50 times
Last edited by Loewchen on Sat Sep 17, 2016 3:47 pm, edited 1 time in total.
Reason: Merged...

chris13524
Fast Inserter
Fast Inserter
Posts: 203
Joined: Thu Jun 04, 2015 12:20 am
Contact:

Re: [HanziQ] [0.14.6] Trains budge when: rail network changes, & every 3s

Post by chris13524 »

I have this issue as well, although I'm not adding/removing anything. In the example below, both trains are set to drive to the shown station (for a PAX station). The second train moves forward for a tick every ~5 seconds or so. Eventually it enters the other block and starts crashing into the first train waiting at the station. The crashing has happened maybe twice in the last hour and luckily I noticed it each time.
Image

User avatar
bioxz
Burner Inserter
Burner Inserter
Posts: 18
Joined: Thu Oct 22, 2015 1:53 pm
Contact:

Re: [HanziQ] [0.14.6] Trains budge when: rail network changes, & every 3s

Post by bioxz »

Can confirm this in 14.9.The train waiting at the signal is slowly moving forward until it has skipped the signal and crashed in the train ahead. Then they will do nasty things until the rear train is out of fuel.

Suitcase08
Burner Inserter
Burner Inserter
Posts: 10
Joined: Sat May 14, 2016 9:22 pm
Contact:

Re: [HanziQ] [0.14.6] Trains budge when: rail network changes, & every 3s

Post by Suitcase08 »

bioxz wrote:Can confirm this in 14.9.The train waiting at the signal is slowly moving forward until it has skipped the signal and crashed in the train ahead. Then they will do nasty things until the rear train is out of fuel.
Ahhh, I was wondering how my stopped trains were running out of fuel. Guess I'll revert for the time being.

User avatar
HanziQ
Former Staff
Former Staff
Posts: 630
Joined: Fri Mar 27, 2015 7:07 am
Contact:

Re: [HanziQ] [0.14.6] Trains budge when: rail network changes, & every 3s

Post by HanziQ »

Should be fixed in the next version.

Post Reply

Return to “Resolved Problems and Bugs”

Who is online

Users browsing this forum: FrankCrins