*[0.13.3][Twinsen] First Steps character death error

This subforum contains all the issues which we already resolved.
Post Reply
User avatar
DaveMcW
Smart Inserter
Smart Inserter
Posts: 3617
Joined: Tue May 13, 2014 11:06 am
Contact:

*[0.13.3][Twinsen] First Steps character death error

Post by DaveMcW »

I saw a couple bug reports on this that didn't get resolved, here is the precise way to reproduce it.

1. Start the First steps campaign, level 2.
2. Follow the tutorial until you get a message to inspect the wooden chest.
3. Don't inspect the wooden chest.
4. Walk north until a biter kills you.

Expected result: You have been defeated...

Actual result:
level-2-bug.jpg
level-2-bug.jpg (55.95 KiB) Viewed 2068 times
I think there is something similar in First Steps 3, but I didn't try to figure out the sequence to reproduce it.

daniel34
Global Moderator
Global Moderator
Posts: 2761
Joined: Thu Dec 25, 2014 7:30 am
Contact:

Re: [0.13.3] First Steps character death error

Post by daniel34 »

Similar bug reports:
[Pending] early play in demo mode, when bug enters (First Steps 2, reproducible in 0.12.35 demo with steps given)
[Pending] LUA Error when saving (First Steps 3)

How to reproduce in First Steps 3 (2 variants):
(1) play until the Get resources (75 iron, 30 copper) objective, get killed by biters (crash in control.lua:242)
(2) play until the "I should make a submachine gun" player message, get killed by biters before crafting one (crash in control.lua:389)
Both times 'character' is nil.
quick links: log file | graphical issues | wiki

User avatar
Klonan
Factorio Staff
Factorio Staff
Posts: 5039
Joined: Sun Jan 11, 2015 2:09 pm
Contact:

Re: *[0.13.3][Twinsen] First Steps character death error

Post by Klonan »

Thanks for the report,

I managed to reproduce the issue,

Here is a savegame for convenience
Attachments
campain2bug.zip
(1.01 MiB) Downloaded 66 times

Twinsen
Factorio Staff
Factorio Staff
Posts: 1243
Joined: Tue Sep 23, 2014 7:10 am
Contact:

Re: *[0.13.3][Twinsen] First Steps character death error

Post by Twinsen »

Fixed in Version: 0.13.8

Post Reply

Return to “Resolved Problems and Bugs”