[Rseding91][1.1.59] Replay just doesn't work anymore with some mods

This subforum contains all the issues which we already resolved.
Post Reply
User avatar
jodokus31
Smart Inserter
Smart Inserter
Posts: 1394
Joined: Sun Feb 26, 2017 4:13 pm
Contact:

[Rseding91][1.1.59] Replay just doesn't work anymore with some mods

Post by jodokus31 »

Version 1.1.59
- Install one of the following mods: angelsrefining, bobassembly.
- Start a new game
- Check replay checkbox
- Walk a bit around.
- Save game
- Try to replay the save file

Result:
Replay button is grey with message: Start replay, Cannot start replay: it has a different mod configuration.

Expected:
Replay button is green and replay starts.

Further info:
- Vanilla only works as expected.
- It still worked as expected in version 1.1.57 with the same mods in the same version.
- Other mods like f.e. bob's adjustable inserters still work
Attachments
factorio-current.log
(5.2 KiB) Downloaded 30 times

Rseding91
Factorio Staff
Factorio Staff
Posts: 12213
Joined: Wed Jun 11, 2014 5:23 am
Contact:

Re: [Rseding91][1.1.59] Replay just doesn't work anymore with some mods

Post by Rseding91 »

Thanks for the report. It's now fixed for the next 1.1 release.
If you want to get ahold of me I'm almost always on Discord.

User avatar
jodokus31
Smart Inserter
Smart Inserter
Posts: 1394
Joined: Sun Feb 26, 2017 4:13 pm
Contact:

Re: [Rseding91][1.1.59] Replay just doesn't work anymore with some mods

Post by jodokus31 »

Great, thank you.
I love the replay feature

Post Reply

Return to “Resolved Problems and Bugs”