[boskid][1.1.53] buildings on multiple networks don't run out of power correctly

This subforum contains all the issues which we already resolved.
Post Reply
AartBluestoke
Inserter
Inserter
Posts: 32
Joined: Sun Jun 29, 2014 4:50 am
Contact:

[boskid][1.1.53] buildings on multiple networks don't run out of power correctly

Post by AartBluestoke »

If a building is on multiple power networks (easiest to do with individual power poles, each connected to a switch, then to the main network) and the main network runs short on power, the building will consume more power than exists on the network and continue to work at higher power.
This came to like when playing Space Exploration, and using an Umbrella to defend from a solar flare ; power draw of several thousand MW is expected. I connnected the umbrella to both a secondary power source, and my bases main power network. I noticed that i was providing it with 1.6GW, and it was drawing 2.3GW, with nothing providing the difference.

0eNqtlttuozAQht/F13aFOYfbPsaqihyYZC2BQbbZlEa8+46hYdOusxtQcoVPn//5PfbkQg51D52WypLiQmTZKkOKHxdi5EmJ2vXZoQNSEGmhIZQo0bhWK2um4SgV6IGMlEhVwTsp+Ej/u7Rrz6CZOUtb/rxZGo5vlICy0kqYJUyNYa/65gAa2X4CxabBRa1yOyKI8ZCSAYEhwjEeBaUbNW74tQ9u0bJCLM4+Sw1TI3AiXnv+fVLydQ6C5933xgqLkqzuwYX+TXLo9+tvyfFLMmuOXhKEV7hXOY8jAr/l5ONBGFkyh+p0W4IxUp0Q5uydojMdQMWatuprYBEpotGjKVo0SYV6cIh1Du/x8SoKP3ykeO2BxM87kN22A0kWyaYRdc2gRi0aTe3a2mdBfrUg9FuQrjcz8pOytWamzzMz32ZmvtXMxG/Bbisv9vN48PDpZLcoukzfG7AWL9nk7ieq1H0F7hI6DOgSNxUnmJ4nvIfYI2yvwUVJCV5Ft0RYVoMwlnhV8vU5dMdAHq50kKdXYnaHGK1Ny/x5acnjbXnJ462JlN5xIXnYhXQCRcFjLmSPuBBudOHP27TED1h+TgPDYg/6KEr4RwTR1zIU0zn0PVaeqv/szAP8UXLoj0ccMfLDXQPX55OTrc3Na02Mphfzba5zrgouf1go+QXazGUy53G2C7OEJzxKg3H8DWyo6yk=
1. observe the refinary basically at full power, running at 1.3MW off a single 600KW power source
2. turn off 3 power switches.
3. observe the refinary running slowly on low power, off the same 600kw power source.

If you replace the creative source with a charged accumulator it lasts the expected 15 seconds in both scenarios.

User avatar
boskid
Factorio Staff
Factorio Staff
Posts: 1785
Joined: Thu Dec 14, 2017 6:56 pm
Contact:

Re: [boskid][1.1.53] buildings on multiple networks don't run out of power correctly

Post by boskid »

Thanks for the report. Issue is now fixed for 1.1.54

Post Reply

Return to “Resolved Problems and Bugs”