Page 1 of 1

[1.1.50] FPS drop when menus/inventory open

Posted: Fri Jan 14, 2022 11:59 pm
by kmey659
1) I noticed after the [1.1.50] update that FPS would suddenly drop when I opened the inventory menu. This occurred in a save game from a previous version. I check my graphics card settings, Vsync, and disabled all mods and the issues persisted.

2) Other menus such as the train, electricity, or production windows resulted in similar FPS drops.

3) I created a new game opened the inventory did not see an FPS drop. I created a sandbox game and included free inventory starter items and experienced an FPS drop when opening the inventory window.

4) I have determined the number of items in the inventory affects the FPS in game. Below I attached a sandbox map and three images. One with the empty inventory window, one with half inventory, and one with full inventory. The level of FPS drop corresponds with the amount of inventory slots occupied.

Re: [1.1.50] FPS drop when menus/inventory open

Posted: Sat Jan 15, 2022 1:27 am
by posila
Are you playing on battery or with charger plugged in?

Re: [1.1.50] FPS drop when menus/inventory open

Posted: Sat Jan 15, 2022 2:41 am
by kmey659
posila wrote:
Sat Jan 15, 2022 1:27 am
Are you playing on battery or with charger plugged in?
I am playing with the charger plugged in. I just checked my energy settings and they are on the right settings. I have not had other FPS hits on other games I have tested (Star Sector and Stellaris) and the drops in Factorio seem to be menu related.

Re: [1.1.50] FPS drop when menus/inventory open

Posted: Sat Feb 12, 2022 12:39 pm
by Timodasilva
Hello,

i have the exact same problem, any suggestions?

Im playing on a pretty strong system not a laptop. I can upload logs and screenshots i neccessary.

Cheers.

Edit: Logfile: https://pastebin.com/CkwmssvF

Screenshot with debug:
20220212135724_1.jpg
20220212135724_1.jpg (651.96 KiB) Viewed 331 times
For me it seems that the gui render time is too high, but I dont know how to fix this. This problems occurs with or withoud mods installed.

EDIT: The force opengl startup option in the steam launch options solved the issue! Im really happy.

Re: [1.1.50] FPS drop when menus/inventory open

Posted: Mon Feb 14, 2022 5:26 pm
by orzelek
Timodasilva wrote:
Sat Feb 12, 2022 12:39 pm
Hello,

i have the exact same problem, any suggestions?

Im playing on a pretty strong system not a laptop. I can upload logs and screenshots i neccessary.

Cheers.

Edit: Logfile: https://pastebin.com/CkwmssvF

Screenshot with debug:

20220212135724_1.jpg

For me it seems that the gui render time is too high, but I dont know how to fix this. This problems occurs with or withoud mods installed.

EDIT: The force opengl startup option in the steam launch options solved the issue! Im really happy.
It seems you have a 144Hz monitor - Factorio really dislikes those for some reason.
Dropping to 120Hz seems to help a bit.