0.17.X Blueprint library lost switching between two computers

Bugs that are actually features.
Post Reply
HiddenWolf
Inserter
Inserter
Posts: 43
Joined: Thu Sep 24, 2015 1:37 pm

0.17.X Blueprint library lost switching between two computers

Post by HiddenWolf » Fri May 17, 2019 4:55 am

I usually play on my desktop PC, which was updated to 0.17.38.
This week I decided to play a little on my laptop, which was at 0.17.X (unknown, several weeks old)
Factorio updated through steam, All mods updated, Last save loaded as expected.
About an hour in, I realised my blueprint library wasn’t complete, but rather the version from a few weeks previous when I last used my laptop.

When I switched back to my desktop the next day, I got a notice through steam that factorio was still open on another computer (it wasn’t, laptop had been off for 18 hours at that point) and I’d have to log off. When I booted the game I could load my latest save, but my blueprint library was the one from a few weeks previous, without the new ones from the last play session.

This might be a fluke, but I don’t think so. I’ve noticed something like this happening before, and I think I can reproduce it with some risk of data loss. I do need some help to figure out what info you need from me to figure this out. What timeline, what logs, what saves and such. I don’t think any of my mods influence the blueprint library, but that could be a consideration as well.

Bilka
Factorio Staff
Factorio Staff
Posts: 1738
Joined: Sat Aug 13, 2016 9:20 am
Contact:

Re: 0.17.X Blueprint library lost switching between two computers

Post by Bilka » Fri May 17, 2019 6:42 am

The blueprint library is not synced with Steam. This makes this not a bug.
I'm an admin over at https://wiki.factorio.com. Feel free to contact me if there's anything wrong (or right) with it.

Post Reply

Return to “Not a bug”

Who is online

Users browsing this forum: No registered users