Version 0.17.9

Information about releases and roadmap.
User avatar
FactorioBot
Factorio Staff
Factorio Staff
Posts: 228
Joined: Tue May 12, 2015 1:48 pm

Version 0.17.9

Post by FactorioBot » Fri Mar 08, 2019 5:41 pm

Changes
  • Disabling station with train waiting in it doesn't force the train to departure anymore so it works as it worked in 0.16. It looked like a useful change for 0.17, but we can control train conditions by circuit network and there are some nice and simple use cases were ruined by trains being forced to departure when the stop is disabled. (65109)
  • Changed expensive version of assembling machine 2 recipe to match the normal version better. (65570)
Minor Features
  • Added map editor support to delete items.
Bugfixes
  • Fixed pipette making error sound in latency state even though you have enough items. (67002)
  • Fixed that technologies would sometimes disappear from the technology list when added to the research queue. (65879)
  • Fixed problems related to circuit network connection inconsistency related to undo. (67071)
  • Fixed NPE issue where Compilatron could destroy essential buildings. (67031)
  • Fixed NPE crash when Compilatron tells you to pick up scrap. (66241)
  • Fixed that he bonus GUI wouldn't show personal equipment. (65618)
  • Fixed using special-item tags would cause desyncs. (66311)
  • Fixed NPE crash when Compilatron tries to point at an object that doesn't exist any more. (65162)
  • Fixed Local errors in scenarios would crash the game when viewing scenarios in the GUI. (66716)
  • Fixed that reviving and underground belt could sometimes change it's direction. (67026)
  • Fixed a crash when using modded recipes in furnaces with fluids. (66271)
  • Fixed that the active-version selector in the mods GUI didn't work. (66941)
  • Fixed that randomizing map seed didn't have any effect after an exchange string was loaded. (65555)
  • Fixed that resources wouldn't be rendered correctly in the map preview. (66525)
  • Fixed miscalculation of peak influence in autoplace specifications with more than 2 peaks. (67040)
  • Layouting fix related to technology gui. (66868)
  • Fixed crash when running out of space in physical texture used for streaming. High detail textures will be evicted instead. (66563)
  • Fixed that mod settings could get scrambled/reset when adding removing or changing mods. (66669)
  • Fixed that you could open blueprint books/armor multiple times. (67096)
  • Fixed that the train inactivity wait condition time was limited to 120 seconds. (66974)
  • Fixed a crash when exiting the game through the "X" button from a tutorial. (65270)
  • Fixed the shadows of some GUIs when circuit network window is shown. (67119)
  • Fixed menu background image would be scaled with poor quality. (67109)
  • Fixed crash related to beam creation when the source or target is removed in the process. (67110)
  • Fixed a hand logic related to loading a save with different mod settings which results in to the cursor being item removed.
  • Fixed being unable to clear "X"(missing blueprint) icon from the quickbar. (67114)
  • Fixed that train two stations of the same name in the train schedule could crash the game. (67066)
  • Fixed consistency check for signal state of train on the way. (67052)
  • Fixed issues with pipes disconnected w/o reason. Added stricter checks for new occurrences. (67057)
Scripting
  • Added LuaSurface::min_brightness read/write.
  • Added LuaEntity::get_connected_rails(), get_rail_segment_entity(), get_rail_segment_end(), get_rail_segment_length(), and get_rail_segment_overlaps().
Use the automatic updater if you can (check experimental updates in other settings) or download full installation at http://www.factorio.com/download/experimental.

tk0421
Long Handed Inserter
Long Handed Inserter
Posts: 63
Joined: Sat Mar 19, 2016 9:36 pm
Contact:

Re: Version 0.17.9

Post by tk0421 » Fri Mar 08, 2019 5:45 pm

yay, automatic updater back in business!

really happy for this, it was taking me 10-15 minutes to install each time. Avast really didnt like the way the installer was working. it would slow my potato down to a crawl, and of course I would always forget to disable avast before running it...

went from .8 to .9 via autoupdater in about 15 seconds total including download

User avatar
MrGrim
Fast Inserter
Fast Inserter
Posts: 201
Joined: Sat Apr 09, 2016 7:58 pm
Contact:

Re: Version 0.17.9

Post by MrGrim » Fri Mar 08, 2019 5:47 pm

FactorioBot wrote:
Fri Mar 08, 2019 5:41 pm
Changes
  • Disabling station with train waiting in it doesn't force the train to departure anymore so it works as it worked in 0.16. It looked like a useful change for 0.17, but we can control train conditions by circuit network and there are some nice and simple use cases were ruined by trains being forced to departure when the stop is disabled. (65109)
Thank you!

Yogzototh
Burner Inserter
Burner Inserter
Posts: 9
Joined: Sun Apr 30, 2017 7:00 pm
Contact:

Re: Version 0.17.9

Post by Yogzototh » Fri Mar 08, 2019 5:52 pm

Oh hey it is now almost a year since the last time i whined about the Expensive Recipes overhaul:
viewtopic.php?f=3&t=58949#p351680
Well i am not giving up. I mean all it takes is just to sit down and crunch some spreadsheets, c'mon.

EmperorArthur
Burner Inserter
Burner Inserter
Posts: 8
Joined: Thu Oct 05, 2017 6:07 pm
Contact:

Re: Version 0.17.9

Post by EmperorArthur » Fri Mar 08, 2019 5:55 pm

Disabling station with train waiting in it doesn't force the train to departure anymore so it works as it worked in 0.16. It looked like a useful change for 0.17, but we can control train conditions by circuit network and there are some nice and simple use cases were ruined by trains being forced to departure when the stop is disabled. (65109)
Appreciate the fix. I use a circuit network to disable stations once they're half filled. I was going to have to manually add a hysteresis memory cell before this patch.

Schallfalke
Fast Inserter
Fast Inserter
Posts: 103
Joined: Sun Oct 28, 2018 7:57 am
Contact:

Re: Version 0.17.9

Post by Schallfalke » Fri Mar 08, 2019 6:21 pm

EmperorArthur wrote:
Fri Mar 08, 2019 5:55 pm
Disabling station with train waiting in it doesn't force the train to departure anymore so it works as it worked in 0.16. It looked like a useful change for 0.17, but we can control train conditions by circuit network and there are some nice and simple use cases were ruined by trains being forced to departure when the stop is disabled. (65109)
Appreciate the fix. I use a circuit network to disable stations once they're half filled. I was going to have to manually add a hysteresis memory cell before this patch.
I appreciate the fix too!! I use multiple platforms to divert trains to platform with enough "empty space", in order to minimize station unloading time. Now the design is working again! :lol:

ColonelSandersLite
Long Handed Inserter
Long Handed Inserter
Posts: 98
Joined: Tue Apr 24, 2018 5:42 am
Contact:

Re: Version 0.17.9

Post by ColonelSandersLite » Fri Mar 08, 2019 6:53 pm

FactorioBot wrote:
Fri Mar 08, 2019 5:41 pm
Use the automatic updater if you can (check experimental updates in other settings)
Woohoo!

Updated from 0.17.8 to 0.17.9 just fine. :D

AngledLuffa
Fast Inserter
Fast Inserter
Posts: 127
Joined: Fri Jan 05, 2018 5:18 pm
Contact:

Re: Version 0.17.9

Post by AngledLuffa » Fri Mar 08, 2019 7:25 pm

The train upgrade is very appreciated. I think the pattern of trains that refill outposts which get turned off halfway through the refill is pretty common.

User avatar
SuperSandro2000
Filter Inserter
Filter Inserter
Posts: 675
Joined: Sun Jan 12, 2014 3:54 am
Contact:

Re: Version 0.17.9

Post by SuperSandro2000 » Fri Mar 08, 2019 8:52 pm

tk0421 wrote:
Fri Mar 08, 2019 5:45 pm
yay, automatic updater back in business!

really happy for this, it was taking me 10-15 minutes to install each time. Avast really didnt like the way the installer was working. it would slow my potato down to a crawl, and of course I would always forget to disable avast before running it...

went from .8 to .9 via autoupdater in about 15 seconds total including download
Get a better or no no AntiVirus.

rldml
Fast Inserter
Fast Inserter
Posts: 168
Joined: Sun Mar 06, 2016 2:38 am
Contact:

Re: Version 0.17.9

Post by rldml » Fri Mar 08, 2019 9:11 pm

Disabling station with train waiting in it doesn't force the train to departure anymore so it works as it worked in 0.16. It looked like a useful change for 0.17, but we can control train conditions by circuit network and there are some nice and simple use cases were ruined by trains being forced to departure when the stop is disabled.
Wait what?

You made trains in 0.17 less usable by design?

Please don't try this ever again ;). Happy to see the 0.16-behavior is back on board.

Greetings, Ronny

nuhll
Filter Inserter
Filter Inserter
Posts: 820
Joined: Mon Apr 04, 2016 9:48 pm
Contact:

Re: Version 0.17.9

Post by nuhll » Fri Mar 08, 2019 9:33 pm

Is there any way to get in touch with the devs about the CDN issue i have? viewtopic.php?p=408576#p408576

I have internet over the biggest company in germany: telekom. my ip is giving back that im from germany, still i get most times a US Server over your CDN.

This is probably the problem which i have while downloading mods, updates and even the whole game (1,2gb).

Slow speeds mostly under 100kbs, for mods most under 20kbs (srsly). "many" disconnects and reconnects. Very anoying.

A fix would be to put my ip range under "germany" (if thats not the case) ( 93.243.197.128 - 93.243.197.207) or give us the ability to static select where we want to download from. (like select it ingame, and (or) under profile at the factorio site)
Last edited by nuhll on Fri Mar 08, 2019 9:35 pm, edited 1 time in total.

Hiladdar
Long Handed Inserter
Long Handed Inserter
Posts: 81
Joined: Mon May 14, 2018 6:47 pm
Contact:

Re: Version 0.17.9

Post by Hiladdar » Fri Mar 08, 2019 9:33 pm

Well, there is a change with the updator, but I am still getting a failure message attempting to updated for 17.8 to 17.9. The OS is W10. Some of the thing I tried was the base update, as well as updating as the administrator. The .zip file still works well.

Hiladdar
Attachments
Not updating to .9.jpg
Not updating to .9.jpg (20.9 KiB) Viewed 8724 times

nuhll
Filter Inserter
Filter Inserter
Posts: 820
Joined: Mon Apr 04, 2016 9:48 pm
Contact:

Re: Version 0.17.9

Post by nuhll » Fri Mar 08, 2019 9:36 pm

Hiladdar wrote:
Fri Mar 08, 2019 9:33 pm
Well, there is a change with the updator, but I am still getting a failure message attempting to updated for 17.8 to 17.9. The OS is W10. Some of the thing I tried was the base update, as well as updating as the administrator. The .zip file still works well.

Hiladdar
Just for the lulz, are you from germany, telekom? :mrgreen:

Hiladdar
Long Handed Inserter
Long Handed Inserter
Posts: 81
Joined: Mon May 14, 2018 6:47 pm
Contact:

Re: Version 0.17.9

Post by Hiladdar » Fri Mar 08, 2019 9:41 pm

nuhll,

I have possible solution for you. Consider using free VPN. Some companies offer free trial, and even free connect, which limit the number of servers you can connect to. That will chance your IP address to that of the VPN server and may solve your problem. Several viable VPN options to look at are ZoogVPN or ProtonVPN. Both of those companies have a presence in EU.

Hiladdar

Hiladdar
Long Handed Inserter
Long Handed Inserter
Posts: 81
Joined: Mon May 14, 2018 6:47 pm
Contact:

Re: Version 0.17.9

Post by Hiladdar » Fri Mar 08, 2019 9:43 pm

nuhll,

I'm from the USA, but on occasion choose to use an IP address registered from a country other then USA.

Hiladdar

bbbower
Manual Inserter
Manual Inserter
Posts: 3
Joined: Mon May 09, 2016 9:38 pm
Contact:

Re: Version 0.17.9

Post by bbbower » Fri Mar 08, 2019 10:08 pm

The arrival campaign is crashing right after you collect the coal, anyone else experiencing that?

nuhll
Filter Inserter
Filter Inserter
Posts: 820
Joined: Mon Apr 04, 2016 9:48 pm
Contact:

Re: Version 0.17.9

Post by nuhll » Fri Mar 08, 2019 10:17 pm

Hiladdar wrote:
Fri Mar 08, 2019 9:41 pm
nuhll,

I have possible solution for you. Consider using free VPN. Some companies offer free trial, and even free connect, which limit the number of servers you can connect to. That will chance your IP address to that of the VPN server and may solve your problem. Several viable VPN options to look at are ZoogVPN or ProtonVPN. Both of those companies have a presence in EU.

Hiladdar
That does not change anything about the bad connection between me and the servers the cdn throws at me... also i will never use a vpn just to get normal speeds... :roll:

But thanks.

User avatar
SuperSandro2000
Filter Inserter
Filter Inserter
Posts: 675
Joined: Sun Jan 12, 2014 3:54 am
Contact:

Re: Version 0.17.9

Post by SuperSandro2000 » Fri Mar 08, 2019 10:58 pm

Hiladdar wrote:
Fri Mar 08, 2019 9:33 pm
Well, there is a change with the updator, but I am still getting a failure message attempting to updated for 17.8 to 17.9. The OS is W10. Some of the thing I tried was the base update, as well as updating as the administrator. The .zip file still works well.

Hiladdar
Incomplete or corrupt download or the devs messed the package up.

Dune
Fast Inserter
Fast Inserter
Posts: 154
Joined: Tue Dec 12, 2017 4:27 am
Contact:

Re: Version 0.17.9

Post by Dune » Sat Mar 09, 2019 4:34 am

MrGrim wrote:
Fri Mar 08, 2019 5:47 pm
FactorioBot wrote:
Fri Mar 08, 2019 5:41 pm
Changes
  • Disabling station with train waiting in it doesn't force the train to departure anymore so it works as it worked in 0.16. It looked like a useful change for 0.17, but we can control train conditions by circuit network and there are some nice and simple use cases were ruined by trains being forced to departure when the stop is disabled. (65109)
Thank you!
Thank you too. I disable stations that have the same name as another with a train parked in it, so the train router would find the open enabled station quicker.
Image

cybersteel8
Inserter
Inserter
Posts: 36
Joined: Sat Aug 27, 2016 1:39 pm
Contact:

Re: Version 0.17.9

Post by cybersteel8 » Sat Mar 09, 2019 4:37 am

SuperSandro2000 wrote:
Fri Mar 08, 2019 10:58 pm
Incomplete or corrupt download or the devs messed the package up.
Yeah I had this too using the core-linux_headless64 package for my server. The delta package didn't seem to update correctly, ended up with the following error when using update_factorio.py after a massive series of logs that unfortunately went above my screen buffer.

Code: Select all

Error Util.cpp:83: Error when opening /opt/factorio/factorio/bin/x64/factorio for reading: Too many open files
I'm not exactly sure how the delta package is applied to the game files so I'm unsure how else to help, but I'm happy to bork up my installation for Wube if they need more information!

Post Reply

Return to “Releases”

Who is online

Users browsing this forum: Bored_Mike, Jelgadis