[posila] [for 0.17] Logistic overlay unusually slow?

This subforum contains all the issues which we already resolved.
Post Reply
bobucles
Smart Inserter
Smart Inserter
Posts: 1566
Joined: Wed Jun 10, 2015 10:37 pm
Contact:

[posila] [for 0.17] Logistic overlay unusually slow?

Post by bobucles » Sun May 27, 2018 7:13 pm

The logistic overlay seems to be very demanding on FPS. Since the overlay doesn't have any moving parts, I was wondering if a bug might be happening. Other than that, running Factorio on a 4K monitor is pure sex.
logistic slow.jpg
logistic slow.jpg (1.49 MiB) Viewed 2011 times
Specs:
8700k i7
GTX 960
16GB RAM
win10 (build 17134)
DirectX 12

posila
Factorio Staff
Factorio Staff
Posts: 3379
Joined: Thu Jun 11, 2015 1:35 pm
Contact:

Re: Logistic overlay unusually slow?

Post by posila » Mon May 28, 2018 11:29 am

The game currently really struggles on 4K displays, so the fullscreen orange layer might have been the last straw. Can you share your save and log (so I can match your graphics settings), please?

bobucles
Smart Inserter
Smart Inserter
Posts: 1566
Joined: Wed Jun 10, 2015 10:37 pm
Contact:

Re: [posila] [for 0.17] Logistic overlay unusually slow?

Post by bobucles » Mon May 28, 2018 3:42 pm

Here's the save .zip with removed mods(yes I removed mods to make sure it still happened) and my system state during the map's logistic view. I'm standing at one of the slower spots. The video card is maxed out and FPS can't keep up.

Hovering over a roboport in normal view doesn't cause the same slowdown. It's strictly a result of the logistic overlay.
logi slow.jpg
system status
logi slow.jpg (598.26 KiB) Viewed 1944 times
Zoom in to this level and click the logistic overlay on and off. It's a huge difference.
Attachments
bug report.zip
save file
(34.17 MiB) Downloaded 19 times

bobucles
Smart Inserter
Smart Inserter
Posts: 1566
Joined: Wed Jun 10, 2015 10:37 pm
Contact:

Re: [posila] [for 0.17] Logistic overlay unusually slow?

Post by bobucles » Mon May 28, 2018 3:55 pm

Whoops! Forgot the log. Windows is set to 150% screen scaling. The regular zoomed out view gives 50% card use and the map view without logistic overlay reports 15%. Win10 reports the usage type as "3D" whatever that means.
save settings.jpg
save settings.jpg (357.95 KiB) Viewed 1941 times
Attachments
factorio-previous.log
(4.26 KiB) Downloaded 24 times
factorio-current.log
(3.86 KiB) Downloaded 21 times

bobucles
Smart Inserter
Smart Inserter
Posts: 1566
Joined: Wed Jun 10, 2015 10:37 pm
Contact:

Re: [posila] [for 0.17] Logistic overlay unusually slow?

Post by bobucles » Sat Jun 09, 2018 2:57 pm

I see the new roboport debug tool. Nice. Unfortunately the roboport overly doesn't seem to be the issue. I did however find the slowdown tied to the "flip[off]" process, whatever that is. I had slowdown on a new game and found the same process eating up the time. Dunno what that's about.
flip.jpg
flip.jpg (227.77 KiB) Viewed 1864 times
Edit: Another part of the base that slows down a huge amount. It is an extremely busy bot outpost that handles all the GC. The difference between overlay and non mode is shown. The "flip" process seems to enjoy jumping between 0.3ms and extreme slowdown with not much difference in between. I couldn't duplicate the effect in my new game, since whatever caused slow down was gone when I restarted.
more stuff.jpg
more stuff.jpg (1.94 MiB) Viewed 1847 times

posila
Factorio Staff
Factorio Staff
Posts: 3379
Joined: Thu Jun 11, 2015 1:35 pm
Contact:

Re: [posila] [for 0.17] Logistic overlay unusually slow?

Post by posila » Wed Oct 24, 2018 10:23 pm

bobucles wrote:
Mon May 28, 2018 3:42 pm
Hovering over a roboport in normal view doesn't cause the same slowdown. It's strictly a result of the logistic overlay.
I am sorry, I've missed this back in May/June, so I didn't realize the problem was due to using less efficient method of drawing the overlay in map (especially when zoomed-in) than in normal game view.

Thanks for the report.
It is fixed for 0.17.

Skeletpiece
Long Handed Inserter
Long Handed Inserter
Posts: 76
Joined: Sat Jul 08, 2017 6:26 pm
Contact:

Re: [posila] [for 0.17] Logistic overlay unusually slow?

Post by Skeletpiece » Thu Nov 22, 2018 3:07 am

bobucles wrote:
Sun May 27, 2018 7:13 pm
.... Other than that, running Factorio on a 4K monitor is pure sex.
:P

Post Reply

Return to “Resolved Problems and Bugs”

Who is online

Users browsing this forum: No registered users