[slpwnd]Found an old 0.10.9 save, that could not be loaded

This subforum contains all the issues which we already resolved.
Post Reply
User avatar
ssilk
Global Moderator
Global Moderator
Posts: 10860
Joined: Tue Apr 16, 2013 10:35 pm
Contact:

[slpwnd]Found an old 0.10.9 save, that could not be loaded

Post by ssilk »

Veeeeery low priority, but maybe it reveals other bugs:

Code: Select all

   0.000 2015-07-24 19:37:35; Factorio 0.12.1 (Build 16116, mac)
   0.000 Operating system: Mac OS X 10.10.4
   0.000 Read data path: /Applications/factorio.app/Contents/data
   0.000 Write data path: /Users/ssilk/Library/Application Support/factorio
   0.000 Binaries path: /
   0.000 Info LocaleProvider.cpp:282: Language en is LTR
   0.000 Info LocaleProvider.cpp:282: Language en is LTR
   0.902 Graphics options: [FullScreen: true] [VSync: true] [UIScale: 100%] [MultiSampling: OFF] [Graphics quality: low] [Video memory usage: high]
   0.944 Loading mod core 0.0.0 (data.lua)
   0.946 Loading mod base 0.12.1 (data.lua)
   1.290 Info LocaleProvider.cpp:282: Language en is LTR
   1.290 Info LocaleProvider.cpp:282: Language en is LTR
   1.291 Info LocaleProvider.cpp:282: Language en is LTR
   1.291 Info LocaleProvider.cpp:282: Language en is LTR
   1.291 Info LocaleProvider.cpp:282: Language en is LTR
   1.291 Info LocaleProvider.cpp:282: Language en is LTR
   1.292 Info LocaleProvider.cpp:282: Language en is LTR
   1.292 Info LocaleProvider.cpp:282: Language en is LTR
   1.409 Initial atlas bitmap size is 16384
   1.410 Created atlas bitmap 16384x2406
  12.039 Info Updater.cpp:720: Downloading https://www.factorio.com/updater/get-available-versions?username=ssilk&token=<private>&apiVersion=2
  12.798 0 packages available to download (experimental updates enabled).
  12.832 Factorio initialised
  19.991 Loading map /Users/ssilk/Library/Application Support/factorio/saves/World7-SplitterTesting1.zip
  20.011 Info Scenario.cpp:160: Map version 0.10.9-0
  20.034 Info PrototypeMigrationList.cpp:99: Activating migration base/2014-10-22_Factorio_0.11.0.json
  20.034 Info PrototypeMigrationList.cpp:99: Activating migration base/2015-06-01_Factorio_0.12.0.json
Factorio crashed. Generating symbolized stacktrace, please wait ...
#0  0x7fff99486f1a in 0x7fff99486f1a
#1  0x0 in 0x0
#2  0x1002eaaa3 in Triangulation::updateTriangulation(std::__1::vector<LogisticCell*, std::__1::allocator<LogisticCell*> > const&, int) (in factorio) + 947
#3  0x1002e86d5 in LogisticTopologyUpdateHelper::deleteCell(LogisticCell*) (in factorio) + 645
#4  0x10016ef84 in Roboport::deactivate() (in factorio) + 564
#5  0x1001704c8 in Roboport::onDestroy() (in factorio) + 24
#6  0x1003c02da in Map::removeDummyEntities(MapDeserialiser*) (in factorio) + 570
#7  0x10039ccbf in Map::setupEntities(MapDeserialiser*, bool) (in factorio) + 2031
#8  0x10003b5ef in Scenario::loadFactory(boost::filesystem::path const*, boost::filesystem::path const&, MapDeserialiser*, InputType, InputHandler*, MultiplayerManager*, std::__1::basic_string<char, std::__1::char_traits<char>, std::__1::allocator<char> >&, bool, ProgressObserver*) (in factorio) + 3567
#9  0x10039a580 in ParallelScenarioLoader::doLoad(ParallelScenarioLoader*, MapDeserialiser*, InputType, InputHandler*, MultiplayerManager*, bool) (in factorio) + 160
#10 0x1008e2776 in boost::(anonymous namespace)::thread_proxy(void*) (in factorio) + 54
#11 0x7fff89baf268 in 0x7fff89baf268
#12 0x7fff89baf1e5 in 0x7fff89baf1e5
#13 0x7fff89bad41d in 0x7fff89bad41d
  23.422 Error Util.cpp:45: Unexpected error occurred. You can help us to solve the problem by posting the contents of the log file on the Factorio forums.
Factorio crashed. Generating symbolized stacktrace, please wait ...
#0  0x7fff99486f1a in 0x7fff99486f1a
#1  0x103008000 in 0x103008000
#2  0x7fff8f62ceb4 in 0x7fff8f62ceb4
#3  0x7fff8f62c37b in 0x7fff8f62c37b
#4  0x7fff8f62bbd8 in 0x7fff8f62bbd8
#5  0x7fff96f8756f in 0x7fff96f8756f
#6  0x7fff96f872ea in 0x7fff96f872ea
#7  0x7fff96f8712b in 0x7fff96f8712b
#8  0x7fff940b98ab in 0x7fff940b98ab
#9  0x7fff940b8e58 in 0x7fff940b8e58
#10 0x7fff940aeaf3 in 0x7fff940aeaf3
#11 0x1007bf15b in _al_osx_run_main (in factorio) + 1675
#12 0x1008e9270 in main (in factorio) + 16
#13 0x100001a84 in start (in factorio) + 52
#14 0x1 in 0x00000001 (in factorio)
  39.172 Error Util.cpp:45: Unexpected error occurred. You can help us to solve the problem by posting the contents of the log file on the Factorio forums.
File:
https://www.dropbox.com/s/tp6ke1ms1pl9j ... 1.zip?dl=0
Cool suggestion: Eatable MOUSE-pointers.
Have you used the Advanced Search today?
Need help, question? FAQ - Wiki - Forum help
I still like small signatures...

slpwnd
Factorio Staff
Factorio Staff
Posts: 1835
Joined: Sun Feb 03, 2013 2:51 pm
Contact:

Re: [slpwnd]Found an old 0.10.9 save, that could not be loaded

Post by slpwnd »

Thanks for the report. It was issue with a modded roboport not being properly removed. Fixed for 0.12.2.

Post Reply

Return to “Resolved Problems and Bugs”

Who is online

Users browsing this forum: No registered users