Bug Reports

Looking for a mod? Have a review on a mod you'd like to share?
Alexs
Fast Inserter
Fast Inserter
Posts: 102
Joined: Sun Sep 07, 2014 9:46 am

Re: Bug Reports

Post by Alexs »

I have exactly the same mistake ...

PiggyWhiskey
Filter Inserter
Filter Inserter
Posts: 251
Joined: Wed May 13, 2015 5:28 am
Contact:

Re: Bug Reports

Post by PiggyWhiskey »

I've found a weird bug.

Playing with .12.8, Bobs Mods and TreeFarm lite.

I have a grid of 16 Mk1 treefarms on grass. Then decided to upgrade all my walking areas to Stone Brick. This killed the growth of the trees (Even though it's still grass underneath)
So I removed the stone brick, and it still doesn't work. The trees refuse to re-grow.

However, there are some fields that didn't have the brick down for that long that are growing. I'm guessing that it only blocks/fails the growth if it experiences a growth tick while there is Stone Brick underneath.
Haven't tested with Concrete.

Re-placing the tree farm removes the "barren" effect.

User avatar
bobingabout
Smart Inserter
Smart Inserter
Posts: 7346
Joined: Fri May 09, 2014 1:01 pm
Contact:

Re: Bug Reports

Post by bobingabout »

Your mod is broken in 0.12.11, something to do with change in scripting.
Creator of Bob's mods. Expanding your gameplay since version 0.9.8.
I also have a Patreon.

User avatar
bobingabout
Smart Inserter
Smart Inserter
Posts: 7346
Joined: Fri May 09, 2014 1:01 pm
Contact:

Re: Bug Reports

Post by bobingabout »

I fixed it myself if anyone is interested.

https://www.dropbox.com/s/4fr6xaq62o9lw ... x.zip?dl=0

I replaced all the script event variables from game. to script. as per the recent changes in 0.12.11.
I also had to replace the game.on_load script with script.on_configuration_changed, as per the devs instructions of "No script should be calling a game. variable on game load, use on_configuration_changed instead.".
the new on_configuration_changed basically detects if the game or any mods have had an update, if they have that function is called.
Creator of Bob's mods. Expanding your gameplay since version 0.9.8.
I also have a Patreon.

PiggyWhiskey
Filter Inserter
Filter Inserter
Posts: 251
Joined: Wed May 13, 2015 5:28 am
Contact:

Re: Bug Reports

Post by PiggyWhiskey »

bobingabout wrote:I fixed it myself if anyone is interested.
sinp
ooh thanks bob.


Another Bug Report.
When robots place a Tree Farm Mk2 it causes a crash to desktop referencing Attempting to index nil.
I think it was code to account for multiplayer (control.lua:196 - local player = game.players[event.player_index])
In single player it doesn't allow indexed players that I could tell.

This mod seems to be dead. Owner hasn't posted since July 29th.

Anyone have any ideas?


Edit: Also happens when bots attempt to fill a MK2 field.
control.lua:383 attempt to index field '?' (a nil value) "if global.tf.seedPrototypes[seedType].efficiency[currentTilename] == nil then"

This stuff is getting well beyond me. I'm hopeless coding unless I can step through it.

Looks like I need to get rid of TreeFarm or stick to MK1's perhaps.

User avatar
bobingabout
Smart Inserter
Smart Inserter
Posts: 7346
Joined: Fri May 09, 2014 1:01 pm
Contact:

Re: Bug Reports

Post by bobingabout »

My fix is inadequate, aparantly the game crashs when a tree would grow.
Creator of Bob's mods. Expanding your gameplay since version 0.9.8.
I also have a Patreon.

User avatar
Lone_Player
Inserter
Inserter
Posts: 44
Joined: Sat Jul 12, 2014 9:56 am
Contact:

Re: Bug Reports

Post by Lone_Player »

Hello,

maybe change to Greenhouses ? -> https://forums.factorio.com/forum/vie ... greenhouse

PiggyWhiskey
Filter Inserter
Filter Inserter
Posts: 251
Joined: Wed May 13, 2015 5:28 am
Contact:

Re: Bug Reports

Post by PiggyWhiskey »

Nice! I didn't even consider trying to find a replacement mod. I'll have a look later tonight.

aklesey1
Smart Inserter
Smart Inserter
Posts: 1845
Joined: Sun May 18, 2014 3:45 pm
Contact:

Re: Bug Reports

Post by aklesey1 »

Error with Factorio 0.12.20 when launching custom scenario
Treedarm Lite control.lua attempt to index global 'game' (a nil value)
I'm using treefarm Ac and Lite with bob mods
Nickname on ModPortal - Naron79

Lee_newsum
Filter Inserter
Filter Inserter
Posts: 433
Joined: Wed Jan 15, 2014 9:41 am
Contact:

Re: Bug Reports

Post by Lee_newsum »

I get this from loading a save game I just save.

Edit loading with the mod and then add it back in fix it so far so good.
Edit2: new game and add it a game works but not loading it with a game with the mod in. :(
Attachments
factorio-current.log
(3.19 KiB) Downloaded 98 times
Treefarm-lite.png
Treefarm-lite.png (719.84 KiB) Viewed 5299 times

Albin00
Burner Inserter
Burner Inserter
Posts: 10
Joined: Tue Jun 03, 2014 7:35 pm
Contact:

Re: Bug Reports

Post by Albin00 »

everytime i try to put a germling into the field this message shows up
Error while running the event handler: __Treefarm-Lite__/control.lua:383: attempt to index field '?' (a nil value)
I can still be in the same world but i can't use the mod. This is very saddening because of the tree producing, myself hate too break down all the trees and then find new ones.

I hoped you fix it :D :) :mrgreen: :(

User avatar
Blu3wolf
Fast Inserter
Fast Inserter
Posts: 202
Joined: Thu Apr 09, 2015 5:20 am
Contact:

Re: Bug Reports

Post by Blu3wolf »

Which version of Treefarm, which version of Factorio?

User avatar
Blu3wolf
Fast Inserter
Fast Inserter
Posts: 202
Joined: Thu Apr 09, 2015 5:20 am
Contact:

Re: Bug Reports

Post by Blu3wolf »

PiggyWhiskey wrote:
bobingabout wrote:I fixed it myself if anyone is interested.
sinp
ooh thanks bob.


Another Bug Report.
When robots place a Tree Farm Mk2 it causes a crash to desktop referencing Attempting to index nil.
I think it was code to account for multiplayer (control.lua:196 - local player = game.players[event.player_index])
In single player it doesn't allow indexed players that I could tell.

This mod seems to be dead. Owner hasn't posted since July 29th.

Anyone have any ideas?


Edit: Also happens when bots attempt to fill a MK2 field.
control.lua:383 attempt to index field '?' (a nil value) "if global.tf.seedPrototypes[seedType].efficiency[currentTilename] == nil then"

This stuff is getting well beyond me. I'm hopeless coding unless I can step through it.

Looks like I need to get rid of TreeFarm or stick to MK1's perhaps.
Fixed the first one. I think I might have fixed the second one? I did a fix, but havent tested it properly as yet. Can find it here: https://github.com/Blu3wolf/Treefarm-Lite/releases

Hope that helps!

Unrated
Manual Inserter
Manual Inserter
Posts: 2
Joined: Sat Apr 02, 2016 6:36 pm
Contact:

Re: Bug Reports

Post by Unrated »

Treefarm-Lite__/control.lua:573: LuaEntity API call when LuaEntity was invalid.

CTD

Three farms producing with germlings. It looks like possibly that it is happening when trees are going from medium to large.

Treefarm Lite Version 0.3.4

Factorio version 0.12.29

Mods:
Advanced Logistics
Autofill
Bob's Mods Suite
EvoGUI
FARL
Fluid Barrel
Initial Scan
Larger Inventory
Rail Tanker
RSO
Smart Trains
TheFatController
Tree Collision
YARM
Last edited by Unrated on Sun Apr 03, 2016 7:16 pm, edited 1 time in total.

User avatar
MiniMe943
Long Handed Inserter
Long Handed Inserter
Posts: 59
Joined: Mon Mar 02, 2015 5:24 am
Contact:

Re: Bug Reports

Post by MiniMe943 »

treefarm_error.png
treefarm_error.png (182.27 KiB) Viewed 5344 times
Getting this error on 12.29 whenever a mature alien tree is automatically selected for deconstruction.

EDIT: Using Treefarm-AC_0.2.3, AlienPlant_0.2.0, and Lite_0.3.1

EDIT, EDIT: Realized I'm using a horribly out of date version of Treefarm, will wait for 0.3.5. :lol:
Last edited by MiniMe943 on Sun Apr 03, 2016 10:02 am, edited 3 times in total.

User avatar
Blu3wolf
Fast Inserter
Fast Inserter
Posts: 202
Joined: Thu Apr 09, 2015 5:20 am
Contact:

Re: Bug Reports

Post by Blu3wolf »

Thanks for the reports guys, I really appreciate them!

Can I get folks to include the version number they were using, of both factorio and the Treefarm mods as well, when you post? Thanks!

Also please note that 0.3.4 is best not used at all right now, it would be better to wait for 0.3.5 due to some awkward bugs.

Unrated
Manual Inserter
Manual Inserter
Posts: 2
Joined: Sat Apr 02, 2016 6:36 pm
Contact:

Re: Bug Reports

Post by Unrated »

Edited my comment with the version number.

Factorio version 0.12.29

Also, put the report on GitHub.

I noticed that the version was pre-released. Reverted back to the previous release, and don't have issues now.

User avatar
Blu3wolf
Fast Inserter
Fast Inserter
Posts: 202
Joined: Thu Apr 09, 2015 5:20 am
Contact:

Re: Bug Reports

Post by Blu3wolf »

Unrated wrote:Edited my comment with the version number.

Factorio version 0.12.29

Also, put the report on GitHub.

I noticed that the version was pre-released. Reverted back to the previous release, and don't have issues now.
Ive gone a step further, and removed the release entirely, due to the game breaking bugs in it. Thanks for putting the report on Github!

0.3.5 is now up, and does not have this game breaking bug any more. As usual, you can download it from the Releases page on Github: https://github.com/Blu3wolf/Treefarm-Lite/releases

Cheers for waiting!

User avatar
MiniMe943
Long Handed Inserter
Long Handed Inserter
Posts: 59
Joined: Mon Mar 02, 2015 5:24 am
Contact:

Re: Bug Reports

Post by MiniMe943 »

Blu3wolf wrote: 0.3.5 is now up, and does not have this game breaking bug any more. As usual, you can download it from the Releases page on Github: https://github.com/Blu3wolf/Treefarm-Lite/releases

Cheers for waiting!
Fantastisch, keep up the great work. This is one of the first mods I ever downloaded for Factorio way back in the day and I'm glad that someone's keeping it alive. :D

Qon
Smart Inserter
Smart Inserter
Posts: 1744
Joined: Thu Mar 17, 2016 6:27 am
Contact:

Re: Bug Reports

Post by Qon »

I can't uninstall this mod. If I try to disable or remove lite and AC or just AC I get an error message preventing me from loading my save file. The performance problems forced be to remove all treefarm items and without them I would like to remove the mod from my savefile. Error mesage attached.
Attachments
ousu(160413-185628-14) - treefarm-error.jpg
ousu(160413-185628-14) - treefarm-error.jpg (29.68 KiB) Viewed 5253 times

Post Reply

Return to “Questions, reviews and ratings”