5Dim Mods

New energy types, decorations, electric train, new types of belts and inserters, bigger inventory and many more stuff.

Moderators: McGuten, odin_spain

Post Reply
scottdl51
Manual Inserter
Manual Inserter
Posts: 2
Joined: Wed Jun 29, 2016 8:30 pm
Contact:

5Dim Mods

Post by scottdl51 »

I downloaded/installed the 5Dim mods through the portal however, they all appear in red when looking at the installed mods. I tried rolling back to 13.0 with no success. Any suggestions?

User avatar
provet
Fast Inserter
Fast Inserter
Posts: 133
Joined: Thu Feb 12, 2015 9:49 pm
Contact:

Re: 5Dim Mods

Post by provet »

scottdl51 wrote:I tried rolling back to 13.0 with no success.
Not sure what you mean by that..

Either you mean that:
5Dim did work in 13.0, but not later versions (current is 0.13.4)
OR
That you weren't able to roll back successfully to 13.0

I got a simple solution for the second problem:
Download the 13.0 version from their website (if you are using steam and didn't know they have all versions here).
go here: http://www.factorio.com/download-headless/experimental and click on the "download page" link. change to experimental releases and download 13.0.

daniel34
Global Moderator
Global Moderator
Posts: 2761
Joined: Thu Dec 25, 2014 7:30 am
Contact:

Re: 5Dim Mods

Post by daniel34 »

Can you post a screenshot of the Mods dialog with one of the 5dim red mods selected? I suspect a missing dependency.
quick links: log file | graphical issues | wiki

scottdl51
Manual Inserter
Manual Inserter
Posts: 2
Joined: Wed Jun 29, 2016 8:30 pm
Contact:

Re: 5Dim Mods

Post by scottdl51 »

I'm sorry for not being more specific. The mods did not work with either version I tried. I've (hopefully) attached the requested screen shot.
Attachments
2016-07-04 (1).png
2016-07-04 (1).png (750.44 KiB) Viewed 4232 times

daniel34
Global Moderator
Global Moderator
Posts: 2761
Joined: Thu Dec 25, 2014 7:30 am
Contact:

Re: 5Dim Mods

Post by daniel34 »

You need to install boblibrary from the mod portal. Then 5dim_core works and the other 5dim mods should as well because they depend on 5dim_core.
If any mods are still red look on the right side under dependencies for red ones and install them (ignore them if they start with a ? questionmark).
quick links: log file | graphical issues | wiki

McGuten
Filter Inserter
Filter Inserter
Posts: 310
Joined: Tue Jun 24, 2014 3:06 pm
Contact:

Re: 5Dim Mods

Post by McGuten »

in next version of 5Dim mods (0.13.1) it will be fixed thanks you for reports.
Image

Post Reply

Return to “5dim's mod”