Page 1 of 1

[1.1.33] Crash While Loading Save

Posted: Tue May 04, 2021 12:55 am
by Zeon0MS
On first start of Factorio after 1.1.33 I tried to load a save that was first created when 1.1 was introduced and it crashed when the loading bar reached the end. I have been unable to load the game. New game creation is still possible, but loading the save from a new game resulted in a crash as well. Save folder for this game is currently at 37290KB (138hr+). Other older saves load, this save does not load however. No Mods are in use or have been used with the save game, it was default settings.

Re: [1.1.33] Crash While Loading Save

Posted: Tue May 04, 2021 10:18 am
by Lou
Hello! Thank you for the feedback.

First of all, enclosed is your fixed save.

Second - your enclosed .log file seems odd - are you sure it is log file corresponding with crash-on-load of your save? I got very different log.

Also, the loading the save resulted in crash in both 1.1.32 and 1.1.33, so it is probable it has nothing to do with version upgrade. Do you remeber what was happening between last succesfull save and the this one? (optimaly autosaves if you still have those)

EDIT: for further investigations my attempts at loading original file failed with "Active entities count doesn't match..."

Re: [1.1.33] Crash While Loading Save

Posted: Tue May 04, 2021 2:27 pm
by Zeon0MS
I don't believe there was anything that occurred between the save, and crashing to open. There are no autosaves after the save I uploaded. It was a few days ago, but I believe I saved the game and quit to desktop with nothing in between.

I realize now that I didn't try any of the autosaves. I just tried the most recent autosave and it crashed as well. The new attachment is the log file from the crash while trying to load the autosave file.

I also verified that the fixed version did load properly. Thank you very much!