[0.17.64] Crash with a furnace-type assembler using fluids and solids

Bugs that we were not able to reproduce, and/or are waiting for more detailed info.
Post Reply
Burner Inserter
Burner Inserter
Posts: 7
Joined: Thu Jul 25, 2019 1:38 pm

[0.17.64] Crash with a furnace-type assembler using fluids and solids

Post by Fuzen777 »

Hey. So I was playing with Space Exploration and Krastorio and I was using one of these Matter Factory which can turn some things into Matter. There was one research about turning Water into Matter, so I tried that - and didn't read that it had to be Pure Water.

Note that Matter Factory appears to be a furnace-type assembler - it automatically selects the recipe depending on what's inside. It has one input slot for solids, and one for fluids and both can be present in the assembler at once even though only one will be used.

Anyway, so Water got into the assembler and I wanted to deconstruct it to clean its content and replace it with the proper fluid. And so I did. I then tried to join the pipe containing Pure Water to the assembler, and strangely enough, the pipe's ghost turned red and I got the fluid mixing error. I tried to deconstruct the Assembler again, and the crash happened. (Not the "unrecoverable error" but the "error window that causes your game to close" one.

I then tried to reproduce the crash and here is what I found.

When trying to use Pure Water to produce Matter, nothing happened. But that's when I noticed that I still had 12 Copper Ores in the Assembler - the recipe requires 20 I believe. I tried to remove these, and that's when the crash happened.

The whole water thing I mentioned had nothing to do with the crash apparently - but there was still that fluids mixing thing even though it was a fresh assembler without any connected pipe.

Here's my factorio-current.log:
First crash - https://pastebin.com/kHrmWaDt
Second crash - https://pastebin.com/1wni0S1M

If the logs are not enough, here's a save from a few minutes before that which I uploaded for a different issue. https://drive.google.com/open?id=1tJKG7 ... L9z03HpVNS

Steps to reproduce - First case (probably - couldn't reproduce it myself):
- Place a Matter Factory
- Place an Infinity Pipe containing Water, let the Factory fill.
- Remove the Infinity Pipe (by hand) and then the Matter Factory (by robots)
- Undo the last action
- Place another pipe containing Pure Water at more than two tiles from the Matter Factory's input
- Deconstruct the Matter Factory

Steps to reproduce - Second case (could reproduce - but doesn't happen every time following these steps. I'm probably missing something.)
- Place a Matter Factory
- Fill it with copper ore (12 in my case)
- Fill it with Pure Water (in my case, by means of a Filtration Plant and Pipes, but should also happen with an Infinity Pipe)
(Normally, at this point, nothing should happen even though Matter Factory can supposedly use Pure Water*.)
- Try to remove the Copper Ores

*Even if the crash doesn't happen, everything up to this point should happen this way - including the fact that the Matter Factory doesn't start using Pure Water.

Former Staff
Former Staff
Posts: 658
Joined: Sat Oct 12, 2013 9:08 am

Re: [Dominik][0.17.64] Crash with a furnace-type assembler using fluids and solids

Post by Dominik »

Hi Fuzen,
the report is quite detailed but I can't find any issue. It certainly does not crash and I am not sure what else is supposed to be wrong.
With the first reproduction - removing the machine erases the water so the water step is irrelevant. And so is a water pipe two tiles away.
The crash is on Recipe::getIngredientStackLimit (triggered by inserter), which is not fluid related, so I will put it out there and maybe somebody else will have some idea. And please, add more info if you can. Thank you.

Post Reply

Return to “Pending”

Who is online

Users browsing this forum: Bing [Bot]