[0.17.62] Desync upon connecting

Bugs that we were not able to reproduce, and/or are waiting for more detailed info.
Post Reply
skrshawk
Manual Inserter
Manual Inserter
Posts: 1
Joined: Mon Aug 05, 2019 4:01 pm
Contact:

[0.17.62] Desync upon connecting

Post by skrshawk » Mon Aug 05, 2019 4:14 pm

First time, be gentle with me. :)

Please refer to the following desync report: https://drive.google.com/file/d/1W22hMV ... sp=sharing

This is the factorio-current.log for this session. https://drive.google.com/file/d/14YngKz ... sp=sharing

I had just connected and didn't have time to do anything in-game. It seemed as though the the map didn't fully load (it loaded much faster than usual for the place this game was at), and then promptly de-synced. I reconnected without any further issue and was fine. Nobody else was in-game at the time it appears. One other player was in game, and he reports he was making a portable solar panel, but that was it.

Game is completely vanilla, not even any sprinkles. I hear about it from players sometimes. :D

If there's anything else you need, please let me know.

posila
Factorio Staff
Factorio Staff
Posts: 3779
Joined: Thu Jun 11, 2015 1:35 pm
Contact:

Re: [0.17.62] Desync upon connecting

Post by posila » Thu Aug 15, 2019 1:21 pm

Investigation: As far as I could find, the desync originated from one of the fluid boxes of oil rafinery on position 254.5, -86.5. It has volume 180 in reference and 100 in desync and invertedBaseArea is 0.55555 (1 / 1.8) in reference and 1.0 in the desync. So base area must have been incorrect on (or incorrectly read from) FluidBoxPrototype.

Little bit of trivia: baseArea on the prototype is double, and double 1.8 is 0x3ffccccccccccccd in hex (or 0x3ffccccccccccccc would be still close enough). Expected value 1.0 would be 0x3ff0000000000000.

As far as I could find, no vanilla fluidbox prototype has base area of 1.8 (in case the fluid box was setup with wrong prototype pointer)

(According to map history, it was created on version 0.17.62)

Adamo
Filter Inserter
Filter Inserter
Posts: 274
Joined: Sat May 24, 2014 7:00 am
Contact:

Re: [0.17.62] Desync upon connecting

Post by Adamo » Thu Aug 15, 2019 1:25 pm

Vanilla oil refineries caused a desync on our games after the introduction of the fluidbox_index, too. The fix is to download the map to your home computer, load it in single player, save it, then upload that back to the server, load from the new saved game file. We had to do that for each map that contained entities using recipes with a fluidbox_index, and all of the maps worked after doing this fix. This is still required by maps that were saved before 17.59 but are being loaded in 17.65 -- so give it a try! Good luck!

Rseding91
Factorio Staff
Factorio Staff
Posts: 9663
Joined: Wed Jun 11, 2014 5:23 am
Contact:

Re: [0.17.62] Desync upon connecting

Post by Rseding91 » Fri Aug 16, 2019 3:38 am

Can you provide the save file that's causing the desync?
If you want to get ahold of me I'm almost always on Discord.

Post Reply

Return to “Pending”

Who is online

Users browsing this forum: No registered users