[0.17.42] Mod manager has bad conrast on some (deactivated?) entry.

Bugs that we were not able to reproduce, and/or are waiting for more detailed info.
Post Reply
User avatar
eradicator
Smart Inserter
Smart Inserter
Posts: 3058
Joined: Tue Jul 12, 2016 9:03 am
Contact:

[0.17.42] Mod manager has bad conrast on some (deactivated?) entry.

Post by eradicator » Wed May 22, 2019 5:23 pm

What?

The color of some of the entries in the mod list has a really bad contrast with the "yellow" selection bar. At first i thought it was every second entry (i.e. alternating table rows) but that doesn't always seem to be true.

Seems to also happen on active entries according to this post but i can't reproduce that.
badconstrast.png
badconstrast.png (41.9 KiB) Viewed 112 times
Author of: Hand Crank Generator, Screenshot Hotkey 2.0
Mod support languages: 日本語, Deutsch, English
My code in the post above is dedicated to the public domain under CC0.

Rseding91
Factorio Staff
Factorio Staff
Posts: 9217
Joined: Wed Jun 11, 2014 5:23 am
Contact:

Re: [0.17.42] Mod manager has bad conrast on some (deactivated?) entry.

Post by Rseding91 » Fri May 31, 2019 3:14 am

Thanks for the report. Do you have any way to reproduce this? When I test, it always shows the correct style on hover/selection.
If you want to get ahold of me I'm almost always on Discord.

User avatar
eradicator
Smart Inserter
Smart Inserter
Posts: 3058
Joined: Tue Jul 12, 2016 9:03 am
Contact:

Re: [0.17.42] Mod manager has bad conrast on some (deactivated?) entry.

Post by eradicator » Fri May 31, 2019 9:22 am

Was a bit baffled because from memory "it's always been like this". But i think i found the pattern. Only mods with an unfullfilled dependency (either factorio version or info.json dependency) show this behavior. GUI debugging says it's "invalid_hovered_mod_label" in all instances, while the other ones are "valid_*".

invalid_hovered_mod_label.png
invalid_hovered_mod_label.png (57.11 KiB) Viewed 33 times
Author of: Hand Crank Generator, Screenshot Hotkey 2.0
Mod support languages: 日本語, Deutsch, English
My code in the post above is dedicated to the public domain under CC0.

Post Reply

Return to “Pending”

Who is online

Users browsing this forum: No registered users