[0.16.51] Save won't load - Unknown tile 46

Post your bugs and problems so we can fix them.
Post Reply
Rob_0128
Manual Inserter
Manual Inserter
Posts: 4
Joined: Sat Feb 02, 2019 7:10 pm
Contact:

[0.16.51] Save won't load - Unknown tile 46

Post by Rob_0128 » Sun Feb 03, 2019 8:01 am

A couple hours ago, I took a break from the game and when i came back, my info.json file was automatically put into my trashcan folder. with some mild amount of trying and multiple corrupted saves (missing Level.dat files etc.) I was finally victorious in my attempt to put the save file back together. it looks exactly like other normal save files I have and has no trouble loading in on the menu anymore (it gave all kinds of error messages when trying to load in) However, if I try to load the map to play it i get an error message saying "unknown tile 46". I have tried to open my info.json file with Microsoft Word, and all files in the savefiles have been zipped and unzipped multiple times. I've posted this to Reddit and couldn't find any solutions, but i saw that some of these save files could indeed be fixed by a developer. Any help is appreciated.

Attachments include the logs and the save file in question.

EDIT: the save file corruption is *probably* caused by an incomplete steam cloud synchronization
Attachments
Corrupt save.zip
(10.79 MiB) Downloaded 2 times
Main World.zip
(6.51 MiB) Downloaded 4 times
factorio-previous.log
(4.57 KiB) Downloaded 3 times
factorio-current.log
(5.26 KiB) Downloaded 5 times
Last edited by Rob_0128 on Tue Feb 05, 2019 6:51 am, edited 2 times in total.

User avatar
TruePikachu
Filter Inserter
Filter Inserter
Posts: 600
Joined: Sat Apr 09, 2016 8:39 pm
Contact:

Re: [0.16.51] Save won't load - Unknown tile 46

Post by TruePikachu » Sun Feb 03, 2019 5:18 pm

My first question would be why info.json got deleted. As far as I'm aware, Factorio doesn't ever have a savegame extracted into its directory structure (instead either dealing with the structure in-memory or on-disk within the zip file), which means something external to the game was in play. I'd naïvely guess antivirus software, but that would usually (a) move files to a quarantine instead of the recycling bin, and (b) remove the entire zip file (for the curious, I just uploaded the "save" to VirusTotal and it didn't pick up on anything).

I might also state that this was the Steam version of the (apparently vanilla) game. Do you have cloud sync enabled for Factorio? While it (probably) wouldn't have done extraction/deletion operations on the save file, it might have caused other difficulties.

My best guess right now is that this is 1/0 related to some external program.

Rob_0128
Manual Inserter
Manual Inserter
Posts: 4
Joined: Sat Feb 02, 2019 7:10 pm
Contact:

Re: [0.16.51] Save won't load - Unknown tile 46

Post by Rob_0128 » Sun Feb 03, 2019 6:52 pm

I don't know why my info.json file was missing. What I do know, however, is that that was not the main problem. If my missing info.json file was missing, it would give an error stating that my info.json file was indeed missing.

Instead, it gave an error stating that my entire save file went bad, and I could indeed not open it at my save file location for factorio. I got this resolved and a "working" save file is now in place. A developer on reddit speculated that it is my level.dat file that is currently corrupted, as is has no problems displaying the save file now, but instead gives the error "corrupt map - Unknown tile 46" when trying to load the file.

User avatar
TruePikachu
Filter Inserter
Filter Inserter
Posts: 600
Joined: Sat Apr 09, 2016 8:39 pm
Contact:

Re: [0.16.51] Save won't load - Unknown tile 46

Post by TruePikachu » Mon Feb 04, 2019 12:46 am

Do you still have a copy of the original corrupted save?

Rob_0128
Manual Inserter
Manual Inserter
Posts: 4
Joined: Sat Feb 02, 2019 7:10 pm
Contact:

Re: [0.16.51] Save won't load - Unknown tile 46

Post by Rob_0128 » Mon Feb 04, 2019 3:47 pm

TruePikachu wrote:
Mon Feb 04, 2019 12:46 am
Do you still have a copy of the original corrupted save?
file is in attachment to this comment.
Attachments
Corrupt save.zip
(10.79 MiB) Downloaded 4 times

User avatar
TruePikachu
Filter Inserter
Filter Inserter
Posts: 600
Joined: Sat Apr 09, 2016 8:39 pm
Contact:

Re: [0.16.51] Save won't load - Unknown tile 46

Post by TruePikachu » Tue Feb 05, 2019 5:32 am

It appears as if either Factorio was interrupted when it was saving the game, or Steam was interrupted when doing cloud sync stuff. The zip file doesn't appear to contain its footer (assuming I'm reading this diagnostic output from 7zip correctly), and all bytes from offset 0x700000 through the end of file (offset 0xACA1E9) are null. (EDIT: And level.dat is definately corrupt as a result; 7zip refuses to extract it)

Does Factorio preallocate exact space for writing a savegame zip file? If it doesn't, the fault is almost certainly outside the game (most likely being Steam, since I know that preallocates).

Rob_0128
Manual Inserter
Manual Inserter
Posts: 4
Joined: Sat Feb 02, 2019 7:10 pm
Contact:

Re: [0.16.51] Save won't load - Unknown tile 46

Post by Rob_0128 » Tue Feb 05, 2019 5:41 am

It's most likely the cloud sync that was interrupted, I put my computer on sleep mode while I was on the main menu 10~ish seconds after I'd saved manually, and after that it was corrupted.

Post Reply

Return to “Bug Reports”

Who is online

Users browsing this forum: No registered users and 3 guests