Crash when loading Autosave

Post your bugs and problems so we can fix them.
Post Reply
burninghey
Burner Inserter
Burner Inserter
Posts: 12
Joined: Fri Sep 14, 2018 2:06 am

Crash when loading Autosave

Post by burninghey » Fri Nov 30, 2018 2:36 am

My game crashed while building a radar in the exact moment autosave hit. This is the first crash I ever encountered in Factorio. Until now, Factorio itself was rock stable, but there is a little problem with steam I'm running into when computer runs for days. Sometimes, when trying to open factorio via steam, it does not work as it should be, shows Steam-Factorio Updating.... Window without doing anything. Then it's best to end steam process via task manager before running Factorio again. Seems to happen only when Factorio did run before without computer reset. This time again, I don't know if it matters or not.

Back to the crash. So game freezed. Did alt-tab into windows, killed factorio process. Started Factorio again. Same problem above. Killed factorio again, steam too. Started Factorio another time. Loaded the autosave (attached below). Crashed instantly after load. Older autosave works flawlessly.

Some mods, nothing really special. Lots of enemies around, because Rampant mod + abused Water fill for invincible wall. In my 10x research expensive game they wiped the floor with me before. Factorio 0.16.51 from Steam, Windows 7 64bit, 16gb ram, i5-6500, Vega 56, Factorio+Steam at system ssd.

tl:dr;
- Crash while building + autosave
- loading this autosave (_autosave3.zip) crashes again immediatly
- strange behaviour with steam when factorio was run before

Uploading savefiles somewhere else, maybe too big? 46mb. Download them here: https://1drv.ms/f/s!AkTNbE8Yl30ZgT9jV4d9JvfphEH8
InstantCrash _autosave3.zip crashes right after game start with rampant enabled
_autosave2.zip from 10min before works

Shitty Internet long upload time gave me some time for further testing. Without mods loading fine. With Rampant instant crash. Seems it's this mod which is causing the crash:
https://mods.factorio.com/mod/Rampant

Will head over there and let him know too.
Attachments
factorio-current.log
(9 KiB) Downloaded 10 times

User avatar
TruePikachu
Filter Inserter
Filter Inserter
Posts: 574
Joined: Sat Apr 09, 2016 8:39 pm

Re: Crash when loading Autosave

Post by TruePikachu » Fri Nov 30, 2018 5:42 am

Well that's disappointing, no crash was actually logged.

As for Steam, is Cloud Sync enabled or disabled? For now at least, I'd recommend disabling it, since it could be contributing to both Steam taking a while to start the game and potential save corruption if it is interrupted.

Post Reply

Return to “Bug Reports”